Sonos and Subsonic remote server

Third-party modifications and add-ons, Apps and Clients

Moderator: moderators

Sonos and Subsonic remote server

Postby AndreasD » Thu Aug 13, 2015 9:21 pm

This afternoon I tried to install Subsonic Music Service into the Sonos system belonging to one of the users of my Subsonic account. I followed the tutorial as listed on subsonic.org and managed to add the Subsonic service into his Sonos system. But when I entered the username and password of my user's Subsonic account, an error (problem) occured and the connection was not made. Of course I entered the right username and password. Same problem occured when I entered my own Subsonic username and password. What could have gone wrong? Thanks.
AndreasD
 
Posts: 10
Joined: Thu Aug 13, 2015 8:48 pm

Re: Sonos and Subsonic remote server

Postby Mr. Odd » Thu Oct 29, 2015 6:47 pm

I have the same problem. Did you ever resolve it?
Mr. Odd
 
Posts: 18
Joined: Sun Aug 15, 2010 1:53 am

Re: Sonos and Subsonic remote server

Postby stueyboy » Fri Oct 30, 2015 9:00 am

Similar problem for me. I've been using an older version of subsonic for a long time and only just updated to V5.3 (build 4568) on Ubuntu server and using Sonos V5.5 (build 29693090) and can't add the account to services.
stueyboy
 
Posts: 46
Joined: Wed Sep 01, 2010 8:58 am

Re: Sonos and Subsonic remote server

Postby sneakybastard » Wed Nov 18, 2015 11:16 pm

hey guys,

has anyone been able to fix this?

my subsonic used to work fine with my sonos, but since the latest subsonic update it has stopped working :-(
sneakybastard
 
Posts: 5
Joined: Wed Feb 22, 2012 3:32 pm

Re: Sonos and Subsonic remote server

Postby dragadog » Fri Nov 20, 2015 12:52 am

I'm having the same issue but I found a semi-working workaround. Following the instructions for using a remote subsonic server at http://www.subsonic.org/pages/sonos.jsp I was able to add subsonic as a custom service. I say "semi-working" because while I can browse, results from subsonic don't show up when searching.

Sucks because I finally bought a sonos this week, after reading about using subsonic to get around the native track limit. :(

I'm actually going to start a new post since I think it's not really the same as the original post.
dragadog
 
Posts: 6
Joined: Mon Jun 28, 2010 12:39 am

Re: Sonos and Subsonic remote server

Postby barnyd » Thu Feb 11, 2016 10:12 pm

Hi , did anyone get to the bottom of this ?

Im running SS on Tomcat on a Synology DS716+ and everything sees to be fine. However when i try to add the Subsonic music service in a Sonos client, after adding in the (correct) username and password i get 'Connection Error - There was a problem adding the Subsonic account - A connection to the server could not be made'

Not really sure whats going on , its all configured correctly to the best of my knowledge. All i can think of is that Sonos is perhaps still looking for a previous SS setup I had on the same network sometime ago on a PI. Would that cause some sort of conflict ?
User avatar
barnyd
 
Posts: 5
Joined: Thu Feb 11, 2016 11:22 am

Re: Sonos and Subsonic remote server

Postby RATTY » Sun Mar 13, 2016 6:54 pm

Hi after spending the day getting subsonic 5.3 on my Nas - I now have this problem has anyone been able to fix it ?

There was a connection problem adding the Subsonic account

A connection to the Subsonic could not be made.

Its definitely talking to the control as this in in the logs

3/13/16 7:29:53 PM GMT+01:00] INFO SonosServiceRegistration Sonos controller returned: <html><head><title>success</title></head><body>success!</body></html>

Cheers

Ratty
RATTY
 
Posts: 12
Joined: Sun Nov 29, 2015 4:19 pm


Return to Mods, Apps and Clients

Who is online

Users browsing this forum: No registered users and 3 guests