Page 1 of 1

Subsonic 4.4 Android App

PostPosted: Wed Jun 01, 2016 8:06 pm
by rts1066
I couldn't find a more appropriate place for this (as none of the sub forums covers the app seemingly).

I've had the Subsonic App connecting to my own Subsonic server (which has a license) on my Sony Xperia Z2 for over a year and since updating Android to version 6.0.1 I can no longer connect. I just get the generic, attempting to connect, attempt 1 through 4 and then the failed to connect message.

The server is definitely working as I can connect through the browser on my phone to same IP and port and successfully log in to the subsonic website. I can also connect using the App on two other phones (one Android 4 and the other 5) with the same credentials which do not work on Android 6.0.1

I've even tried using Ultrasonic on the Sony which shows the exact same error.

Does anyone have the Android app working with their own server in Android 6.0.1?

Re: Subsonic 4.4 Android App

PostPosted: Wed Jun 01, 2016 8:48 pm
by acroyear
I've got 4.4 working on a 6.0.1 Galaxy S6 with no issues at all. Sorry, can't say much more than that. It just worked, though I have to say the phone was originally Android 5.1 first, and upgraded later after purchase and Subsonic installation.

However, my server is NOT https, nor am I using the * redirect, both of which I can imagine might cause an issue somewhere in the network stack. Not will, merely might. No promises.

Re: Subsonic 4.4 Android App

PostPosted: Wed Jun 01, 2016 9:01 pm
by rts1066
Thanks. I'm not using * redirect either.

Oddly, I can connect to the demo server on Android 6.0.1. I was on Android 5 till the weekend (when it updated).

Re: Subsonic 4.4 Android App

PostPosted: Wed Jun 01, 2016 9:39 pm
by rts1066
Does any one know how/if it's possible to enable useful logging/debugging output?

Re: Subsonic 4.4 Android App

PostPosted: Tue Aug 16, 2016 7:04 pm
by rts1066
After ignoring this for two months (and using an old phone instead) - I've now formatted the SD card in this phone and factory reset the phone and reinstalled the Subsonic app.

Subsonic still fails to connect with a generic 'A network error occurred...' error.

This is the only device subsonic has stopped working on and I know the phone can connect to the given server and port (as I can login to the web browser (connecting to the same IP and port) using the chrome app).

Does anyone else know anything else I can try to fix this?