DLNA Doesn't work

Need help? Post your questions here.

Moderator: moderators

DLNA Doesn't work

Postby dtacheron » Sun Feb 25, 2018 4:56 pm

Hi,

Subsonic last version (02/25/2018). Ubuntu 16.04 LTS.

uname -a
Linux NAS 4.4.0-116-generic #140-Ubuntu SMP Mon Feb 12 21:23:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

java -version
openjdk version "1.8.0_151"
OpenJDK Runtime Environment (build 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12)
OpenJDK 64-Bit Server VM (build 25.151-b12, mixed mode)

DLNA player and Subsonic are on the same LAN.

i can't read music with a dlna player (i tried with 2 differents players that work with Windows 10 Media Streaming).

the player browse the files correctly but when you try to play a song, it iterates over all songs without producing music.
[2018-02-25 16:54:11,385] INFO FolderBasedContentDirectory - UPnP request - objectId: 0, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 64
[2018-02-25 16:54:23,459] INFO FolderBasedContentDirectory - UPnP request - objectId: folder-1, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 64
[2018-02-25 16:54:49,182] INFO FolderBasedContentDirectory - UPnP request - objectId: folder-41, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 64
[2018-02-25 16:54:55,670] INFO FolderBasedContentDirectory - UPnP request - objectId: folder-872, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 64
[2018-02-25 16:55:11,139] INFO FolderBasedContentDirectory - UPnP request - objectId: folder-44, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 64
[2018-02-25 16:55:13,976] INFO FolderBasedContentDirectory - UPnP request - objectId: folder-951, browseFlag: BrowseDirectChildren, filter: *, firstResult: 0, maxResults: 64
[2018-02-25 16:55:17,893] WARN SecurityService - Unauthenticated access attempt: You Could Have It So Much Better

i tried with mp3 files (no transcoding) and other files.
i play songs normaly with the web interface

video here : https://drive.google.com/file/d/1bLRyL6JEJsRaEybPb82xJtmrAsXCQ2fm/view?usp=sharing
detail setup, logs etc here :https://drive.google.com/file/d/1F3SqHtl0P4kdx0Bxor2Q-2NnbBROn367/view?usp=sharing

It looks like a bug.

Thanks 4 help.

PS :
i'll try to increase the log verbosity (found the war, i'll take a look at).
dtacheron
 
Posts: 4
Joined: Sun Feb 25, 2018 4:37 pm

Re: DLNA Doesn't work

Postby dtacheron » Sun Feb 25, 2018 5:09 pm

Logs are here : https://drive.google.com/file/d/1i1mXpFkBC0hLwxKhjk_SlbUJOWS7rYQL/view?usp=sharing

it seems that there is a problem with memory allocation

java.lang.NullPointerException
at net.sourceforge.subsonic.controller.StreamController.handleRequest(StreamController.java:80)
at net.sourceforge.subsonic.controller.StreamController.handleRequest(StreamController.java:66)

i'll re-try with a tail on the log file
dtacheron
 
Posts: 4
Joined: Sun Feb 25, 2018 4:37 pm

Re: DLNA Doesn't work

Postby dtacheron » Sun Feb 25, 2018 5:16 pm

ok, problem is here (net.sourceforge.subsonic.controller.StreamController)

Player player = this.playerService.getPlayer(request, response, false, true);
User user = this.securityService.getUserByName(player.getUsername());
try
{
if (!user.isStreamRole())
{
response.sendError(403, "Streaming is forbidden for user " + user.getUsername());
return null;
}

NullPointerException.
user object seems not allocated.
dtacheron
 
Posts: 4
Joined: Sun Feb 25, 2018 4:37 pm

Re: DLNA Doesn't work

Postby dtacheron » Sun Feb 25, 2018 5:42 pm

It works with subsonic android app.

it seems like you need to authenticate, and that dlna player not designed specifically with this in mind will not work properly ?
dtacheron
 
Posts: 4
Joined: Sun Feb 25, 2018 4:37 pm

Re: DLNA Doesn't work

Postby intangir » Wed Aug 08, 2018 8:12 pm

I had the same issue and found the answer:

login as admin, goto USERS

goto GUEST, set it to be able to play files, and give it access to your folders

also you can goto players, and look under the guest user, if you see that the last time guest was on was when you tried your DLNA/UPnP client, then its surely using guest access

i set it and it worked for me
intangir
 
Posts: 3
Joined: Mon Feb 13, 2012 3:51 am


Return to Help

Who is online

Users browsing this forum: No registered users and 0 guests