New to Madsonic: Help installing Madsonic on RedHat/Fedora

Madsonic Mashup Mod is a fork of the Subsonic 4.7 Server Build 3090 with some Subsonic Data schema modifications!

Moderator: moderators

New to Madsonic: Help installing Madsonic on RedHat/Fedora

Postby Robocop » Sun Jan 27, 2013 1:27 pm

Hi there, I am currently using a VPS host for my Subsonic server, for which I have FTP over SSH and root access. Subsonic was working and installed all ok, but I wanted to give Madsonic a try. I have managed to grab the 4.8 .rpm package (as I believe GigaPros uses RedHat/Fedora for my VPS, and everything looks ok up until it seems to do a check for dependancies and I get the following when trying to install both manually, and via yum:

rpmlib(FileDigests) is needed by madsonic-4.8.beta3-3320.i386
rpmlib(PayloadIsXz) is needed by madsonic-4.8.beta3-3320.i386


I have made sure java 1.7.0 (JDK) is installed, but not sure how to work around this error. The subsonic 4.7.rpm installed fine on the VPS as long as the --nogpgcheck command was used.

Any ideas or assistance will be greatly received, thanks in advance.

Robocop.
User avatar
Robocop
 
Posts: 8
Joined: Sun Jan 27, 2013 1:07 pm

Re: New to Madsonic: Help installing Madsonic on RedHat/Fedo

Postby bushman4 » Mon Jan 28, 2013 4:50 pm

I'm not a linux user, but why not just install the packages that are required?

I believe these are required for the enhanced upload manager...

Glenn
Glenn Sullivan
Subsonic 5.2.1 (Standalone on Apache/Tomcat 6)
WHS 2003, Dual Core Athlon, 4 Gb RAM, 12 TB
50 regular Subsonic Users

Library as of 2016-03-21:
4,034 artists
16,595 albums
182,904 songs
4582.16 GB
21,558 hours
User avatar
bushman4
 
Posts: 867
Joined: Thu Dec 02, 2010 1:47 pm
Location: Massachusetts, USA

Re: New to Madsonic: Help installing Madsonic on RedHat/Fedo

Postby Robocop » Tue Jan 29, 2013 7:35 pm

Hi Bushman,

The Filedigests and Payloads are not actual packages you can install - they must be part of the .rpm installer itself on the OS.
I did some more digging around - it seems I can install Madsonic 4.7 versions without this issue, it's only the 4.8 beta I'm having an issue with now.
I'm wondering if it is down to the age of the OS on the GigaPros VPS - looks like it is CentOS 5.3.

Robocop.
User avatar
Robocop
 
Posts: 8
Joined: Sun Jan 27, 2013 1:07 pm

Re: New to Madsonic: Help installing Madsonic on RedHat/Fedo

Postby newburns » Mon Mar 25, 2013 2:35 am

Same issues here. Looking to install 4.7 now, and do a full write up on my installation.
Using SME 8.0 (distribution based on Centos 5/RHEL)
newburns
 
Posts: 3
Joined: Sun Jun 17, 2012 5:08 am


Return to Madsonic

Who is online

Users browsing this forum: No registered users and 1 guest