Trouble transcoding to VBR

Need help? Post your questions here.

Moderator: moderators

Trouble transcoding to VBR

Postby rubbersoul » Fri Mar 06, 2015 3:08 am

I updated my ffmpeg and lame .exe files in the subsonic\transcode folder and want to change my transcoding profile from 320kbps to the more efficient vbr (v2) profile. I used the following string directly from the command line and it created the vbr transcoded file just as I desired:

ffmpeg -i test.flac -c:a libmp3lame -q:a 2 test.mp3

Now I'm trying to figure out how to get the above line to work in the subsonic transcoding setting. I'm confused how to specify the output file... I've tried:

ffmpeg -i %s -c:a libmp3lame -q:a 2 output.mp3
ffmpeg -i %s -c:a libmp3lame -q:a 2 %t.mp3
ffmpeg -i %s -c:a libmp3lame -q:a 2 -f mp3 -
ffmpeg -i %s -map 0:0 -c:a libmp3lame -q:a 2 -f mp3 -

Only the last one gives any output whatsoever, but the resultant files are claimed to be 32kbps (though the file size and sound quality doesn't seem to agree with that). Is it possible that the transcoding is working, just displaying the bitrate in dSub funny for some reason? My ears tell me this cannot be 32kbps encoding, haha!
rubbersoul
 
Posts: 127
Joined: Thu Aug 18, 2011 2:27 pm

Return to Help

Who is online

Users browsing this forum: No registered users and 18 guests