6.0.beta1 (build 4676) breaks external player permissions

Need help? Post your questions here.

Moderator: moderators

6.0.beta1 (build 4676) breaks external player permissions

Postby bru » Thu Feb 11, 2016 12:54 am

Problem

After upgrading it seems that external players all give messages such as:

Unable to open item for playback (Access to file 41195 is forbidden for user mike (403)):

Built in player continues to function just fine.


Steps taken
I've tried recreating the user, recreating players, and every variation thereof.

Logs look like:

[2016-02-10 16:51:46,290] DEBUG StreamController - GET /stream?player=49&id=41199&suffix=.flac, Range: null
[2016-02-10 16:51:46,294] WARN SecurityService - Unauthenticated access attempt: Fullmoon

Not sure if this will help:
Code: Select all
select * from user_role where username='mike'

USERNAME   ROLE_ID
mike   1
mike   2
mike   3
mike   5
mike   6
mike   7
mike   8
mike   9
mike   10
mike   11
mike   12
bru
 
Posts: 10
Joined: Thu Nov 10, 2011 7:19 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby bru » Fri Feb 12, 2016 4:12 am

No one else is having an issue like this? I searched the forums and saw a similar issue in an older version, but it seemed slightly different as it could be solved by deleting users/players.
bru
 
Posts: 10
Joined: Thu Nov 10, 2011 7:19 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby stringbot » Sun Mar 06, 2016 3:14 pm

I am having the same issue with 6.0.beta1 (build 4676). At first I thought it was because my Premium account expired the same day I installed the beta, but renewing the Premium account did not solve the problem.

[3/6/16 9:08:01 AM CST] DEBUG StreamController GET /stream?player=18&id=67052&suffix=.mp3, Range: bytes=0-
[3/6/16 9:08:01 AM CST] WARN SecurityService Unauthenticated access attempt: Daabi
[3/6/16 9:08:02 AM CST] ERROR NowPlayingService Unexpected error in getNowPlaying: java.lang.SecurityException: Access denied to file /Volumes/Drobo/Media/lossless/The Orb/Alpine/01 Alpine Morning.flac

Seems like it might be a file system permissions issue?
stringbot
 
Posts: 3
Joined: Sun Mar 06, 2016 3:10 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby stringbot » Sun Mar 06, 2016 3:14 pm

Interestingly, my Sonos player still works fine
stringbot
 
Posts: 3
Joined: Sun Mar 06, 2016 3:10 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby bru » Mon Mar 07, 2016 6:13 pm

My sonos works fine too. It's very strange.

I've been stuck using the built in player instead of foobar, which is my preference. I double checked file system privileges as well, but nothing changed there.
bru
 
Posts: 10
Joined: Thu Nov 10, 2011 7:19 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby stringbot » Tue Mar 08, 2016 5:02 am

After further testing, I can stream to the external player if I select the "External Player" option and enable mp3 transcoding. It does not work if I select the "External Player with Playlist" option, with or without mp3 transcoding enabled.

I noticed this thread on the General forum: viewtopic.php?f=5&t=16316 and I have a suspicion that the API for file playback changed but maybe the m3u playlist generator doesn't (or can't) use the new API?
stringbot
 
Posts: 3
Joined: Sun Mar 06, 2016 3:10 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby bru » Tue Mar 08, 2016 11:20 pm

Ah.

I can confirm that external player works for me too, but I can't play entire albums. Only one song at a time.

External player with playlist seems to be the common denominator here.

Also, unless I use active mp3 transcoding, even the internal player won't work with raw flac.

Can Sindre comment?
bru
 
Posts: 10
Joined: Thu Nov 10, 2011 7:19 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby jesperdahls » Wed Mar 09, 2016 7:20 am

I got same problem, when using external player with playlist.
Any news on fixing it.?
jesperdahls
 
Posts: 1
Joined: Wed Mar 09, 2016 7:15 am

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby GrenDup » Wed Mar 09, 2016 1:59 pm

Hello!
Same here...
GrenDup
 
Posts: 15
Joined: Sun Apr 05, 2009 5:33 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby bru » Thu Mar 24, 2016 9:59 pm

I upgrade to beta2 and still have this issue. Is someone looking into this? I think this is the biggest thread about a 6.x bug so far.


Thanks,
bru
bru
 
Posts: 10
Joined: Thu Nov 10, 2011 7:19 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby Jägs » Fri Mar 25, 2016 4:07 am

Just adding my name to the list of those experiencing this issue:

[3/24/16 11:05:18 PM CDT] DEBUG StreamController GET /music/stream?player=1&id=33360&suffix=.mp3, Range: null
[3/24/16 11:05:18 PM CDT] WARN SecurityService Unauthenticated access attempt: Walk on Water

I'm on beta 2.
Jägs
 
Posts: 98
Joined: Wed Apr 06, 2011 9:52 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby Jägs » Fri Mar 25, 2016 10:27 pm

Out of curiosity, I grabbed one of the URLs from VLC and pasted into a browser:

(URL: mydomain.com/music/stream?player=1&id=60556&suffix=.mp3)

HTTP ERROR: 403

Access to file 60556 is forbidden for user eric
RequestURI=/music/stream

Powered by Jetty://

I do have this defined in the Subsonic settings under "Access your server over the Internet using an easy-to-remember address." The URL is set to: http://mydomain.com/music. If I don't do this, per the issue here--http://forum.subsonic.org/forum/viewtopic.php?f=2&t=16084--it plugs in a local IP address and the default port, despite accessing it via a remote URL.
Jägs
 
Posts: 98
Joined: Wed Apr 06, 2011 9:52 pm

Re: 6.0.beta1 (build 4676) breaks external player permission

Postby sindre_mehus » Mon Mar 28, 2016 1:18 pm

Sorry, my mistake :oops:

The URLs in the generated m3u were missing the authentication tokens (that were introduced in 6.0).

Will be fixed in the next version.

Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway


Return to Help

Who is online

Users browsing this forum: No registered users and 5 guests