Sonos / Subsconic / Synology problem

Need help? Post your questions here.

Moderator: moderators

Sonos / Subsconic / Synology problem

Postby subi2000 » Tue Jul 09, 2019 8:08 pm

I've installed subsonic on my synology 1512+ together with Java8.
I can login to subsonic with the ip from my nas and port 4040. I've added my music library, enabled sonos service inside subsonic and not more (the sonos feature will be available to August, before i must by a premium licence).

After installation i have the Subsonic music service inside my LAN on my Sonos System. When i try to add this and login with the admin user, i'll get an error after 10-20 seconds, that there is a connection error and a problem adding the subsonic account.

What can i do to fix it ?
Posts: 1
Joined: Tue Jul 09, 2019 8:03 pm

Re: Sonos / Subsconic / Synology problem

Postby Jk12 » Thu Aug 29, 2019 6:01 am

Same setup. Same issue. I made the mistake of paying for subsonic though thinking that’s why Sonos wouldn’t login. I’m able to use my subsonic web and iOS apps just fine. However, Sonos just won’t login. That’s why I just setup subsonic—-to replace pocketcast. Since it’s been a few months and no response I’ll take that to mean this has been abandoned or was never supported.
Posts: 1
Joined: Thu Aug 29, 2019 5:54 am

Re: Sonos / Subsconic / Synology problem

Postby eqd » Wed Feb 12, 2020 1:18 am

I had this problem as well.. the issue (for me at least) was the startup script was specifying a host IP of to bind to, letting Subsonic try to figure it out for itself. When it made the connect to the Sonos speakers, it informed the speakers that its IP was in the bogus unassigned range (169. ...). Changing the host ip listed in /usr/syno/synoman/webman/3rdparty/subsonic/ to be the actual IP of the Synology NAS solves the issue (for me - YMMV.)
Posts: 1
Joined: Wed Feb 12, 2020 1:16 am

Re: Sonos / Subsconic / Synology problem

Postby richs99 » Tue Feb 23, 2021 5:50 pm

I am also having this problem.

I've freshly installed subsonic on my Synology NAS, I can play music on the NAS from the JamStash chrome plugin AND the MusicBee app on my windows PC. I can see the Synology service within the Sonos apps (have tried windows and android).

I try to connect to it, it asks for my username and password, and then the message that:
Code: Select all
There was a problem adding the Subsonic account.

A connection to Subsonic could not be made.

I've now tried editing the file and replaced the IP with the IP of my NAS but I am getting the same error after restarting the NAS.

Anyone got any other ideas?

Posts: 1
Joined: Tue Feb 23, 2021 5:02 pm

Re: Sonos / Subsconic / Synology problem

Postby bjtukker » Thu Feb 25, 2021 3:17 pm

I think Sonos prevents unlicensed music services since recently, unfortunately. Here's the list they registered:
Posts: 5
Joined: Sun Sep 21, 2014 2:31 pm

Return to Help

Who is online

Users browsing this forum: No registered users and 18 guests