SOLVED - 503 Error - Debian 10 Upgrades

Need help? Post your questions here.

Moderator: moderators

SOLVED - 503 Error - Debian 10 Upgrades

Postby vantseattle » Sun Apr 05, 2020 2:13 am

I'm posting here hoping someone else had a similar issue. On the same Debian server that I have been running Subsonic for years I recently installed Nginx in order to attempt to do some video feeds. At this point I was running Debian 9. I upgraded to Debian 10 and the video streams that I was testing with Nginx were successful. Would installing Nginx overdo any web/url settings that Subsonic would have configured previously?

Subsonic is currently showing running but produces a error 503 when trying to access the webpage.

Current troubleshooting:
Installed PHP 7.1 and 7.2 per another post I saw on here, verified that PHP 7.1 is currently running as the default version. Confirmed by "php -v"

Debian 10 comes packaged with Java 11. Installed and set Java 8 as the default version. Confirmed by running "java -version"

I had already removed all of the files in the /var/subsonic/db folders and restarted services and it will not re-create the database file.

Additionally I had uninstalled Subsonic and Installed multiple times using "dpkg -P subsonic" to remove all items and "dpkg -i subsonic-6.1.6.deb" to reinstall.

Local Subsonic account has permissions to everything in /var/subsonic/

I'm kind of at a loss here as I've followed most other recent posts on this Reddit thread and this post as well by linuxbabe: https://www.linuxbabe.com/ubuntu/instal ... 8-04-https

I even did the .properties update listed in this post: viewtopic.php?f=2&t=17957

Looking for other help from those running Debian 10.
Last edited by vantseattle on Sun Apr 05, 2020 4:51 am, edited 1 time in total.
vantseattle
 
Posts: 2
Joined: Sun Apr 05, 2020 2:05 am

Re: 503 Error - Debian 10 Upgrades

Postby vantseattle » Sun Apr 05, 2020 4:51 am

We're back in business. Here were the steps I backtracked:
-Removed Nginx and kept it from launching from boot "sudo systemctl stop nginx && sudo systemctl disable nginx"
-Removed Subsonic "sudo dpkg -P subsonic"
-Removed Subsonic folder at /var/subsonic
-Rebooted
-Installed download file of Subsonic. I'm rebuilding my database and userbase but whatever it's running.
vantseattle
 
Posts: 2
Joined: Sun Apr 05, 2020 2:05 am


Return to Help

Who is online

Users browsing this forum: No registered users and 18 guests