SubSonic Help Request

Need help? Post your questions here.

Moderator: moderators

SubSonic Help Request

Postby cfw34683 » Sat Dec 26, 2020 9:09 pm

Hello, I have been running sub sonic for some time now without issue. Just a week ago or so I have been seeing errors in the logs regarding XML tags and files. I have attempted to resolve these myself but the code from the errors is not enough for ME to figure out. Is anyone able to decipher these?

<-------------------------Subsonic Help Request---------------------->
Problem Description: Just a week ago or so I have been seeing errors in the logs regarding XML tags and files.
Troubleshooting Steps:I have attempted to correct the errors but without knowing what files to edit it makes it difficult. I also deleted the jetty folder as a whole and let it regenerate and these errors are still appearing
Playback Application and version: play:sub (but this has nothing to do with it)
Subsonic Version: 6.1.6 (build 0cfa60) – November 10, 2019
Server Version: jetty-6.1.x, java 1.8.0_275, HSQLDB, Linux (154.1 MB / 393.5 MB)
Hardware Platform: Linux Ubuntu 20.10 subsonic ran in a screen -dRR music
Java Memory Limit: 700
Problem Filename: *.xml
Output from ffmpeg -i:none this has nothing to do with it
Last ten log file lines:
Code: Select all
5937 [main] INFO org.springframework.web.servlet.DispatcherServlet - FrameworkServlet 'subsonic': initialization completed in 683 ms
5945 [main] INFO org.mortbay.log - Started SelectChannelConnector@0.0.0.0:4040
Subsonic running on: http://localhost:4040/music
5973 [main] INFO org.springframework.remoting.rmi.RmiServiceExporter - Looking for RMI registry at port '9412'
5980 [main] INFO org.springframework.remoting.rmi.RmiServiceExporter - Could not detect RMI registry - creating new one
6002 [main] INFO org.springframework.remoting.rmi.RmiServiceExporter - Binding service 'SubsonicDeployerService' to RMI registry: RegistryImpl[UnicastServerRef [liveRef: [endpoint:[127.0.1.1:9412](local),objID:[0:0:0, 0]]]]
50626449 [btpool0-1] INFO org.directwebremoting.log.startup - Starting: DwrServlet v3.0.0-FINAL on jetty-6.1.x / JDK 1.8.0_275 from Private Build at /music
50626988 [btpool0-1] INFO org.directwebremoting.log.startup - Starting: Using container abstraction org.directwebremoting.server.servlet2.Servlet24ContainerAbstraction
50627015 [btpool0-1] INFO org.directwebremoting.servlet.UrlProcessor - Probably not an issue: the url:/gi.js (org.directwebremoting.gi.GiHandler) Handler is not available. This is only an problem if you wanted to use it.
[Fatal Error] :371:51: XML document structures must start and end within the same entity.
[Fatal Error] :1169:15: XML document structures must start and end within the same entity.
[Fatal Error] :168:15: The content of elements must consist of well-formed character data or markup.
[Fatal Error] :310:11: Attribute name "siz" associated with an element type "image" must be followed by the ' = ' character.
[Fatal Error] :906:86: XML document structures must start and end within the same entity.
[Fatal Error] :1089:81: XML document structures must start and end within the same entity.
[Fatal Error] :171:68: XML document structures must start and end within the same entity.
[Fatal Error] :789:100: The element type "image" must be terminated by the matching end-tag "</image>".
[Fatal Error] :453:51: XML document structures must start and end within the same entity.
[Fatal Error] :212:85: XML document structures must start and end within the same entity.
[Fatal Error] :814:28: XML document structures must start and end within the same entity.
[Fatal Error] :749:7: XML document structures must start and end within the same entity.
[Fatal Error] :176:13: XML document structures must start and end within the same entity.

<-------------------------Subsonic Help Request---------------------->

I am assuming that the 176:13 is the line and column of the file that i need to fix. BUT what is the specific file?
cfw34683
 
Posts: 8
Joined: Sat Dec 26, 2020 9:01 pm

Re: SubSonic Help Request

Postby cfw34683 » Sun Dec 27, 2020 9:55 pm

As an update i tried the first error
Code: Select all
[Fatal Error] :371:51: XML document structures must start and end within the same entity.

i went thru every page i could in the jetty file and i found 0 instances of anything at line 371 column 51.
so I tried this one
Code: Select all
[Fatal Error] :310:11: Attribute name "siz" associated with an element type "image" must be followed by the ' = ' character.

this also led me down a dead end. Then i used,
Code: Select all
grep -Rilnw '/path/to/jetty/' -e 'siz'

to try and find the siz error and that returned every find of the siz including the word size

this is hopeless
cfw34683
 
Posts: 8
Joined: Sat Dec 26, 2020 9:01 pm

Re: SubSonic Help Request

Postby cfw34683 » Fri Jan 01, 2021 1:33 am

Happy New Year Bump`1
cfw34683
 
Posts: 8
Joined: Sat Dec 26, 2020 9:01 pm

Re: SubSonic Help Request

Postby cfw34683 » Tue Jan 05, 2021 4:12 pm

This newest error brings the service to its knees!


Code: Select all
[Fatal Error] :378:85: An invalid XML character (Unicode: 0x0) was found in the element content of the document.
cfw34683
 
Posts: 8
Joined: Sat Dec 26, 2020 9:01 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 23 guests