Can't add new music

Need help? Post your questions here.

Moderator: moderators

Can't add new music

Postby Boutros » Fri Feb 26, 2021 7:08 pm

I'm back on Subsonic after using the MusicCabinet mod for about 8 years, and while I'm liking it a lot in many ways, I have one major problem that has me almost ready to give up on SS once and for all and check out Airsonic or something. I can't add new music to my collection.

When I did the initial installation and media scan, everything worked great. However, I'm completely unable to add any additional media to it. I've tried dropping a new album folder into the media folder, and also using the Upload function (which shows my zip file uploading and unzipping successfully). I've even had a friend upload something from outside my network.

In all these scenarios though, the new files... just never show in the UI, even after multiple folder scans (which show no errors). They just don't get added, either in "Recently Added" or in the Index itself. The only way to make them accessible is to uninstall SS, and do a complete fresh install with a new initial scan, etc. Obviously not sustainable. *EDIT* I did find another slightly less clunky workaround that I detailed in my Friday Mar 12 post downthread, but not a solution:
Boutros wrote:a) Went into GUI and DELETED media folder
b) Ran "Clean-up database" (not sure if this actually has anything to do with anything, but just to be on the safe side)
c) Stopped the server
d) Re-started the server, then re-ADDED it and SAVED and rescanned it

I'm on a Windows 10 box, with my Media folders living on a standard external HD connected directly to the machine via USB - not a NAS or anything.

Is anyone else running into problems with this? Does anyone have any advice?
Last edited by Boutros on Fri Mar 12, 2021 3:28 pm, edited 4 times in total.
Boutros
 
Posts: 117
Joined: Mon Jun 06, 2011 6:09 pm

Re: Can't add new music

Postby heylookltsme » Sun Feb 28, 2021 2:39 pm

Sounds like maybe a permissions issue. I would check that the user running subsonic has read/write permissions to the files you've added.
heylookltsme
 
Posts: 5
Joined: Sat Sep 12, 2015 12:05 pm

Re: Can't add new music

Postby edwardrudman@cox.net » Wed Mar 10, 2021 12:19 am

I am having the same problem. Running Subsonic on my Windows 10 machine, with my library on an external hard drive, the "K" drive. I access Subsonic through Sonos. I can play all the songs (177,00+) in there currently, but today I:

1) added a few albums to the folder system on K: drive
2) went into the GUI and rescanned the music library.
3) new albums didn't show up
4) Went into GUI and DELETED music library, then re-ADDED it and SAVED and rescanned it
5) new albums still didn't show up.

Any other ways to "refresh" the library?

Ed R.
edwardrudman@cox.net
 
Posts: 4
Joined: Sun Dec 02, 2018 8:21 pm

Re: Can't add new music

Postby Boutros » Fri Mar 12, 2021 3:22 pm

Ed R., I was able to successfully refresh the library, using basically the same routine you listed below, but I think the difference was in your 4). Mine looked like:

4a) Went into GUI and DELETED media folder
4b) Ran "Clean-up database" (not sure if this actually has anything to do with anything, but just to be on the safe side)
4c) Stopped the server
4d) Re-started the server, then re-ADDED it and SAVED and rescanned it

Again, I don't know enough about anything to know how/why this worked, but it did for me. Obviously still not a great long-term solution since I have a huge library and re-scanning the main folder takes hours, but at this point I'm resigned to doing it monthly if no one can figure out how to make this work as intended...

This is all really making me miss MusicCabinet, where not only did the folder scan work every time, but if you uploaded a song through the GUI it automatically scanned in just that album folder, making it accessible instantly...

edwardrudman@cox.net wrote:1) added a few albums to the folder system on K: drive
2) went into the GUI and rescanned the music library.
3) new albums didn't show up
4) Went into GUI and DELETED music library, then re-ADDED it and SAVED and rescanned it
5) new albums still didn't show up.
Boutros
 
Posts: 117
Joined: Mon Jun 06, 2011 6:09 pm

Re: Can't add new music

Postby acroyear » Fri Mar 12, 2021 9:25 pm

Question - are there any 'foreign' characters in the file or folder name? I've found that having things like Ö (Blue Oyster Cult, for example) will cause the files to not be recognized. I even wrote a bit of node.js javascript (originally java) to clean up the file names. Subsonic is fine having them in the album/artist/song ID3 info, but it can't handle the physical file names.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 721
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Can't add new music

Postby Boutros » Fri Mar 12, 2021 10:12 pm

Hi acroyear - long time no speak :)

No, unfortunately, no unusual characters. I wish it was as simple as that, for sure, but this condition persists for every folder that wasn't in the directory before the initial successful scan.

acroyear wrote:Question - are there any 'foreign' characters in the file or folder name? I've found that having things like Ö (Blue Oyster Cult, for example) will cause the files to not be recognized. I even wrote a bit of node.js javascript (originally java) to clean up the file names. Subsonic is fine having them in the album/artist/song ID3 info, but it can't handle the physical file names.
Boutros
 
Posts: 117
Joined: Mon Jun 06, 2011 6:09 pm

Re: Can't add new music

Postby G8DHE » Sat Mar 13, 2021 10:19 am

Are you certain that the new added folders have the same access rights for the user account that subsonic is running under ?
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 107
Joined: Sun Nov 04, 2012 4:56 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 15 guests