Continous playback issue

Need help? Post your questions here.

Moderator: moderators

Continous playback issue

Postby af_muc » Fri Oct 28, 2022 4:11 pm

Hi, I am using subsonic on a MacMini M1 under Chrome and cannot playback live albums continously. Any idea why? This is quite disturbing, since a crack sound is created also when moving to the next song. Anything I can do here ot overcome the problem? I am facing the same issue when running the "substreamer app" on my iPhone 12 Pro Max, just without the cracking.
Any help is appreciated. Thanks
PS
Hope I am using the correct forum for my question ... :-)
af_muc
 
Posts: 3
Joined: Fri Oct 28, 2022 3:47 pm

Re: Continous playback issue

Postby G8DHE » Sat Oct 29, 2022 8:48 am

So what happens when you try to play back continuously ? What type of file are you trying to playback ? Does it playback other files ? Is the "crack" the problem or is that just another effect ?
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 139
Joined: Sun Nov 04, 2012 4:56 pm

Re: Continous playback issue

Postby Exrace » Tue Nov 01, 2022 9:40 pm

af_muc wrote:Hi, I am using subsonic on a MacMini M1 under Chrome and cannot playback live albums continously. Any idea why? This is quite disturbing, since a crack sound is created also when moving to the next song. Anything I can do here ot overcome the problem? I am facing the same issue when running the "substreamer app" on my iPhone 12 Pro Max, just without the cracking.
Any help is appreciated. Thanks
PS
Hope I am using the correct forum for my question ... :-)

What are you using to playback when cracking occurs and what are your encoding settings?
Exrace
 
Posts: 218
Joined: Thu Nov 11, 2010 5:02 am

Re: Continous playback issue

Postby acroyear » Thu Nov 03, 2022 2:12 pm

what is your speaker and how is it connected?

with my phone, sometimes that happens with some bluetooth speakers because when the audio stops, the bluetooth connection is 'silenced' (battery saver) and then re-opened when the next song starts, and i do have a speaker that causes a crackle in.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 774
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Continous playback issue

Postby af_muc » Thu Nov 17, 2022 1:25 pm

Thanks for getting back to me with you replies ...
I am using the generic user interface that comes with the Subsonic server app (web interface under Chrome and MacOS 12.6).
I am streaming with either Bluetooth or AirPlay to a Network Streamer from either Yamaha or Hama. Signal then goes into my Amp (AMC) and playout to my Dynaudio Stereo HiFi Loudspeakers.
The little break in between the music pieces that are supposed to play back continuously happens with both formats I am using - FLAC and MP3 (and with all my different bitrates).

When running the playback from my iPhone (using the "substreamer" App) I can hear the "crack" (sometimes - not always). But the little, noticeable break remains. Annoying when listen to live music ... :-(
af_muc
 
Posts: 3
Joined: Fri Oct 28, 2022 3:47 pm

Re: Continous playback issue

Postby acroyear » Wed Nov 23, 2022 12:50 am

the pauses are because subsonic's main player, and most of the apps, don't buffer up subsequent files. they start playing one when the prior one stops. They have to wait for that event.

And then the startup of the new file of course has to buffer up enough bytes to start playing.

So in that, yes, the bluetooths might get a "nothing's playing" moment and some models will crackle when they stop or start. Just the nature of the older tech there.

Not really a 'cure' as such. I've thought about adding some continuous (that is, overlapping) code to Subfire, by basically having two audio tags so one is always buffering up the next track in the queue and ready to go the instant the other stops. But it hasn't gotten past the thought about it stage.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 774
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA

Re: Continous playback issue

Postby af_muc » Mon Dec 12, 2022 12:25 pm

Hi "acroyear"
I managed to address the problem on the iOS side by using the "play:Sub" app.
I do understand the buffering issue (and downstream why the "bluetooth" cracks appear), but wonder why this issue did not come up with other users. :-)
Other question: Is there any recommendation for a Mac OS app that supports the "substreamer server" and FLAC (with continues playback of course)?
Best of thanks ... :-)
af_muc
 
Posts: 3
Joined: Fri Oct 28, 2022 3:47 pm

Re: Continous playback issue

Postby acroyear » Thu Dec 22, 2022 2:28 am

I think other users are used to it and don't worry about it. I know I wouldn't mind fixing the problem (it definitely affects the main Android app on my Samsung tablet + bluetooth), but I just ignore it after a time.
--
Joe Shelby
http://subfiresuite.com/
http://subfireplayer.net/
User avatar
acroyear
 
Posts: 774
Joined: Wed Mar 27, 2013 8:05 pm
Location: Northern, VA


Return to Help

Who is online

Users browsing this forum: No registered users and 27 guests