Network directory problems

Need help? Post your questions here.

Moderator: moderators

Network directory problems

Postby Kryten » Wed Oct 11, 2023 9:45 pm

Hi All,

I have setup the service to logon and added a load of folders from a network drive, but it says folder not found. The folders are on drive E:
Any suggestions?

Regards
Mark
Kryten
 
Posts: 6
Joined: Wed Oct 11, 2023 9:41 pm

Re: Network directory problems

Postby G8DHE » Thu Oct 12, 2023 9:34 am

Does the "service" have logon access to the remote drives ?
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 139
Joined: Sun Nov 04, 2012 4:56 pm

Re: Network directory problems

Postby Kryten » Fri Oct 13, 2023 11:19 pm

I'm not sure, how would I check that?
Kryten
 
Posts: 6
Joined: Wed Oct 11, 2023 9:41 pm

Re: Network directory problems

Postby G8DHE » Sat Oct 14, 2023 11:12 am

When you created the service it will have a logon to an account, if this account doesn't have access outside the local machine resources then it won't be able to use the network.
Perhaps you need to read up on creating services in the Help system for your operating system ?
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 139
Joined: Sun Nov 04, 2012 4:56 pm

Re: Network directory problems

Postby Kryten » Sun Oct 15, 2023 2:56 pm

Seems to me that nobody knows the answer. Probably easier to install on the machine that has the drives locally. Which isn't what I want. I understand that a service cannot access locally assigned drive letters from what I have read in the net. I followed the logon as a user in the service as detailed, but that doesn't work.
Kryten
 
Posts: 6
Joined: Wed Oct 11, 2023 9:41 pm

Re: Network directory problems

Postby G8DHE » Sun Oct 15, 2023 4:43 pm

Part of the problem is you haven't told us what OS your running or version of Subsonic either!
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 139
Joined: Sun Nov 04, 2012 4:56 pm

Re: Network directory problems

Postby Kryten » Sun Oct 15, 2023 4:47 pm

I'm running Windows 11 with the latest version of subsonic
Kryten
 
Posts: 6
Joined: Wed Oct 11, 2023 9:41 pm

Re: Network directory problems

Postby G8DHE » Sun Oct 15, 2023 9:29 pm

So did you create it in the "LocalService" account in which case this likely applies https://learn.microsoft.com/en-us/windo ... ce-account
You need to create the service under an account that has network access to the machine and drive that the files are on.
Geoff G8DHE
Version 6.0 Beta 2
G8DHE
 
Posts: 139
Joined: Sun Nov 04, 2012 4:56 pm

Re: Network directory problems

Postby Kryten » Mon Oct 16, 2023 4:26 am

I've set it up on the local machine now, but the problem is it's saying that my sub domain starbugbbs is in use on subsonic.org. How do I change it so that it points to the correct IP address? I've changed my router to point to the new device already. When I enter starbugbbs.subsonic.org it goes to the wrong internal IP
Kryten
 
Posts: 6
Joined: Wed Oct 11, 2023 9:41 pm

Re: Network directory problems

Postby Kryten » Mon Oct 16, 2023 5:22 am

It's ok, it's working now
Kryten
 
Posts: 6
Joined: Wed Oct 11, 2023 9:41 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 14 guests