Page 3 of 3

Re: Selecting audio card in jukebox mode?

PostPosted: Tue Apr 28, 2015 12:29 pm
by wintrmute
I switched to the official Java 8 runtime, and that solved *half* the problem. I now didn't need to put any stupid extra parameters in - it just found the Pulseaudio system and send audio to all outputs.

However I hit a NEW problem. For some reason, the outputs are always Muted, and I have to unmute every time I start playing.
(alsamixer, then scroll over to the output and hit M)
Disabling "auto-mute" didn't fix it in ALSA so.. i don't know.

Give MPD a try instead of Subsonic?

Re:

PostPosted: Tue Feb 16, 2016 5:28 am
by jebsky
maxslug wrote:
johngc wrote:
I then added the line as directed in my /usr/bin/subsonic file (does it matter where is should be in it?)


Hi John, yes position counts too :) It's got to be on the extended line that starts the process. the backslash (\) wraps a long line to make it more readable. This line will start with 'java'or '$JAVA' or '${JAVA}'.

Here's a snip of my file for reference :

Code: Select all
${JAVA} -Xmx${SUBSONIC_MAX_MEMORY}m \
  -Dsubsonic.home=${SUBSONIC_HOME} \
  -Dsubsonic.host=${SUBSONIC_HOST} \
  -Dsubsonic.port=${SUBSONIC_PORT} \
  -Dsubsonic.httpsPort=${SUBSONIC_HTTPS_PORT} \
  -Dsubsonic.contextPath=${SUBSONIC_CONTEXT_PATH} \
  -Dsubsonic.defaultMusicFolder=${SUBSONIC_DEFAULT_MUSIC_FOLDER} \
  -Dsubsonic.defaultPodcastFolder=${SUBSONIC_DEFAULT_PODCAST_FOLDER} \
  -Dsubsonic.defaultPlaylistFolder=${SUBSONIC_DEFAULT_PLAYLIST_FOLDER} \
  -Djava.awt.headless=true \
  '-Djavax.sound.sampled.SourceDataLine=#NVidia [plughw:0,7]' \
  -jar subsonic-booter-jar-with-dependencies.jar > ${LOG} 2>&1 &


Make sure there are no spaces after any of the backslashes.

-m


Wow I have never been able to get jukebox to work on a linux server and with this info I finally got it to work. wow

Re: Selecting audio card in jukebox mode?

PostPosted: Mon May 09, 2016 2:02 am
by jebsky
I had to redo this when I updated to 6.0

my line
Code: Select all
'-Djavax.sound.sampled.SourceDataLine=#PCH [plughw:1,0]' \

Re:

PostPosted: Sat May 14, 2016 12:35 pm
by webvan
sindre_mehus wrote:The easiest option is perhaps to set the USB device as the default audio device in Linux.

http://www.cahilig.org/select-default-a ... ubuntu-804

Alternatively, you can add the following system property when launching Subsonic from subsonic.sh (assuming you're using the standalone version of Subsonic):
Code: Select all
-Djavax.sound.sampled.SourceDataLine=#name_of_audiodevice


I haven't tried this on Linux, but it works on Windows. For instance, I have two devices called "SigmaTel Audio" and "SB Live! 24-bit External". To select the first I would do:
Code: Select all
"-Djavax.sound.sampled.SourceDataLine=#SigmaTel Audio"


Hope this helps!


I'm trying to select the soundcard for the Jukebox mode in windows but I'm not seeing a subsonic.sh file in the /subsonic directory, I must be missing something? Thanks for any help!

Re: Selecting audio card in jukebox mode?

PostPosted: Sun Mar 18, 2018 5:31 am
by studiojurdan
hum, this is too complicate and is not for my "openmediavault in debian 8" version
when SUBSIONIC will THINK about an install file that REALY WORKS on the target made for?

Re: Selecting audio card in jukebox mode?

PostPosted: Sat Jan 19, 2019 2:50 pm
by zeroth
I have the HiFiberry DAC+ and It's verified working and I can get sound on the system. It shows in the list of sound cards as card below. However, when I do the script and output audio devices I only see Pulseaudio Mixer. I don't know the actual hardware name so I can put in the Subsonic Config. I'm sure that is all I need to figure out. Any ideas? I guess the main issue is that that Java is not seeing the HifiberryDAC and therefore not outputting the hardware when I run the code?

0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

Re: Selecting audio card in jukebox mode?

PostPosted: Sun Feb 16, 2020 6:51 pm
by AgentX83
All these years later...and this solution is no longer a viable process. It seems that I can't compile the suggested script due to Java versioning. I even upgraded my local Java JRE and JDK (which, I'll add, then prevents SubSonic from even responding to web requests and presents the ugly 503 Unavailable error).

Anyone have a more current solution? I'd really love to stream my SubSonic content from my RaspPi4 to a BlueTooth receiver I have in my home arcade.