Sonos & subsonic

General discussions.

Moderator: moderators

Sonos & subsonic

Postby lemonyelow1 » Wed Nov 18, 2020 6:31 pm

Kind of surprised to see that the newest (as of 11/18/2020, I think) Sonos Android App (called S2) no longer includes Subsonic as a recognized service. Plex is, ... and I can't help but wonder if they bought "exclusivity," i.e., got Sonos to de-list Subsonic for some amount of money. NO LOVE for Sonos, obviously (and deservedly), but I'd LOVE To make the connection between my subsonic PC-based library and a variety (gen 1 and gen 2) Sonos speakers. The Sonos software is buggy as all get out, but I don't think the page showing 100 or so "services" omitted Subsonic via a programming error. IS there a workaround. I'm not the most tech-savvy individual, but I've seen other similar (to Subsonic) services essentially "trick" Sonos and others into thinking one's server is a "broadcaster." (One winds up with an http:// critter that essentially plays music.)
lemonyelow1
 
Posts: 2
Joined: Wed Nov 18, 2020 6:18 pm

Re: Sonos & subsonic

Postby bjtukker » Fri Feb 19, 2021 2:33 pm

You can (or should I say could?) add the service yourself: http://www.subsonic.org/pages/sonos.jsp. But for me, that is also no longer working.
bjtukker
 
Posts: 5
Joined: Sun Sep 21, 2014 2:31 pm

Re: Sonos & subsonic

Postby djdonnerwolke » Sun Apr 18, 2021 11:55 am

I am currently also looking for a solution to my problem and I have the impression that I can no longer use my Sonos speakers with Subsonic.
In the past it always worked and now all of a sudden it doesn't work anymore.
Is there any other solution that can be implemented?

I am sad to read your posts, because now I have the impression that it really doesn't work anymore.
Has anyone been able to restore the functionality?

Greetings.
djdonnerwolke
 
Posts: 3
Joined: Sun Apr 18, 2021 11:51 am

Re: Sonos & subsonic

Postby ozzyrb5 » Tue May 04, 2021 9:17 am

I've switched my music to Plex which works with Sonos (I have a mix of Play 1, Play 3 from around 2015 and new Ikea Symfonisk speakers)

I've just downloaded Subsonic and set it up (default port 4040) on my media PC (Windows 10) and was able to add it back as a service via the Sonos Desktop App and iPhone app (iPhone 7 IOS 14.6 public beta 2. Both are running the S2 app.

I've heard of issues with complex passwords not working so I've tested with the out-the-box login details.
ozzyrb5
 
Posts: 14
Joined: Tue Jul 23, 2013 11:29 pm


Return to General

Who is online

Users browsing this forum: No registered users and 5 guests