My Experience Installing on Mac Using the Install Package

Tutorials, tips and tricks.

Moderator: moderators

My Experience Installing on Mac Using the Install Package

Postby mtmorris » Fri Mar 09, 2012 12:20 pm

Hi, I'm new here. Apologies if this is not the right group for this topic, but it seemed to make the most sense.

I installed Subsonic on a Mac (OS X 10.5.8) last night and ran into into a few minor issues. I thought I would try to save others a few headaches by posting my experience here. Especially since I'm going to spread word about this software like wildfire!

First, the install package for Subsonic 4.6 ( ... ic-4.6.pkg) seemed to work fine. No visible errors. But, from there I could not get the Control Panel up. I was getting an error in a pop-up screen (sorry I don't remember exactly what it said and I didn't write it down).

At any rate, I checked the log file and eventually figured out that the application couldn't create the "jetty" and other directories in the ~/Library/Application Support/Subsonic folder. Upon inspection, the permissions on that folder had been set by the installer as "drwxr-xr-x". Having been a UNIX developer back in the day, I was suspicious that the folder probably needed "w" (write) permissions for the group. I tried a few "chmod" commands but for some reason they didn't take (even using "sudo"). I ended up just pulling up Mac Finder, navigating to that folder and hitting the "Get Info" option. From there I set read/write permission to the "admin" user and made sure to apply to all subfolders using the gear options thing. After doing that, the Control Panel came right up. I confirmed in the log file and also saw that directories were now being written to the ~/Library/Application Support/Subsonic folder, including "jetty."

The next problem I ran into was that .m4a files that I had purchased from iTunes wouldn't play, while .mp3's did. From searching this Forum I saw where Sindre had said that version 4.6 played .m4a files natively. So I went to the Transcoder settings page and simply removed "m4a" from the "Convert from" file type list under the "mp3 audio" transcoder. I almost deleted the entire transcoder, but then realized that just removing the one file type was probably smarter, so I could keep the rest of transcoder settings for other file types. That worked like a charm, and .m4a files bought from iTunes started playing right away. This, was a relief as I didn't want to have to convert all my AAC files to MP3 files (been building this music library for about 15 years).

That was about it. I installed iSub on my iPhone and bam! This software is amazing. I've been looking for something to do this for many, many years. Incredible work, Sindre. I'll be sending the money for my key as soon as I can do a few more days of testing ;)

Posts: 1
Joined: Fri Mar 09, 2012 11:57 am

Re: My Experience Installing on Mac Using the Install Packag

Postby BKKKPewsey » Fri Mar 09, 2012 9:34 pm

Welcome and thank you for the informative and helpful post.
I am making this a sticky as I am sure any mac/subsonic newbies will find it most useful :)
Everyone is entitled to be stupid, Image but some abuse the privilege!

Due to the confusion from too many genres of music, we have decided to put both country music and rap music into the genre of Crap music.
User avatar
Posts: 2080
Joined: Mon May 23, 2011 12:16 pm
Location: United Kingdom

sorry duplicate post

Postby postjosh » Tue Aug 12, 2014 4:01 pm

Last edited by postjosh on Tue Aug 12, 2014 4:17 pm, edited 1 time in total.
Posts: 15
Joined: Sun Aug 10, 2014 6:15 pm

Re: My Experience Installing on Mac Using the Install Packag

Postby postjosh » Tue Aug 12, 2014 4:16 pm

yes. i had a similar experience installing subsonic on snow leopard os x 10.6.8. the install was incomplete and i had to find the Library/Application Support/Subsonic folder and change system permissions to read/write. this can be done easily using the get info command (cmd i on the keyboard). then i reinstalled and everything worked fine.

4.9 (build 3819) – January 23, 2014 jetty-6.1.x, java 1.6.0_65, Mac OS X (68.3 MB / 147.9 MB)
Posts: 15
Joined: Sun Aug 10, 2014 6:15 pm

Re: My Experience Installing on Mac Using the Install Packag

Postby postjosh » Fri Jan 16, 2015 5:23 pm

i spent a fair amount of time figuring how to integrate the subsonic server with itunes playists on my snow leopard mac mini. i thought it would be helpful to document my procedure with subsonic 4.9:

• export playlist from itunes (there's a great donationware script called "batch export playlists")
• under the general settings, point subsonic to your exported itunes playlists for playlist import
• under media folders settings, point subsonic to your itunes music folder for media scanning
• set scan media folders to never
• click on "scan media folders now"

in order add itunes playlists later, it is necessary to delete all your existing playlists and repeat the process above. here are the steps:

  • go to http://localhost:4040/db.view (you can substitute your server name for localhost)
  • type DELETE FROM PLAYLIST and click ok. (be careful this will delete ALL your playlists)
  • check the server to make sure the playlists are erased
  • under settings click "clean-up database."
  • wait a few minutes for the clean-up to complete
  • follow the earlier procedure to export playlists from itunes and load them into subsonic
i have over 500 playlists and this works fine for me.
Posts: 15
Joined: Sun Aug 10, 2014 6:15 pm

Re: My Experience Installing on Mac Using the Install Packag

Postby Socnicme » Mon Apr 10, 2017 7:22 pm

I'm a Mac user for an year now and well, most of a programs installation casino invoice is a problem. A problem to fix, but still I prefer using Subsonic on Windows.
Posts: 1
Joined: Mon Apr 10, 2017 7:17 pm

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 2 guests