Folder/album is lost when its tags are changed

Need help? Post your questions here.

Moderator: moderators

Folder/album is lost when its tags are changed

Postby Jaarde » Thu Sep 14, 2017 5:02 pm

If I change tags of tracks and scan the library again, Subsonic looses those tracks and won't show them at least in frontend player. No matter if I rescan or cleanup database and rescan after that, it won't find the tracks anymore.
Jaarde
 
Posts: 2
Joined: Sat Aug 26, 2017 10:55 am

Re: Folder/album is lost when its tags are changed

Postby Souldrinker » Sat Sep 30, 2017 8:28 pm

Yup, the same happens to me. I've gone through my library recently and improved the tagging (and sometimes replaced the files with higher bitrate versions) on several of my albums, but now all of the recently updated albums are gone. They albums themselves are still there with info about them and when they last were played, but all the tracks are missing. Any ideas how to fix this?
Souldrinker
 
Posts: 13
Joined: Fri Jan 07, 2011 11:18 pm

Re: Folder/album is lost when its tags are changed

Postby Souldrinker » Sat Sep 30, 2017 8:58 pm

I checked the albums for one artist of which I recently updated tags and/or quality on some of the albums that now had disappeared and temporarily copied those away, did a clean-up database, put them back and rescanned and then the tracks got back (and the last played info still seemed to exist even after the clean for example played 8 times, last time in August 2015 or played 1 time in October 2010 etc.).

But remembering/finding all albums I've updated and moving them away, clean-up and rescanning those seems like quite a hassle. Any chance of getting this bug fixed?
Souldrinker
 
Posts: 13
Joined: Fri Jan 07, 2011 11:18 pm

Re: Folder/album is lost when its tags are changed

Postby Souldrinker » Sat Sep 30, 2017 9:15 pm

After some further investigation it seems like all the files I updated up to May 28th seem to have worked (the tracks are still there), but from May 31th and onwards all updated files seems to have disappeared from subsonic. And when looking at the version.txt in the Subsonic folder (on my Win2016 server) it says 6.1.1 and is updated on 2017-05-31, so it seems this bug was introduced with the 6.1.1 version.

So I guess for now I can find all files changed since that date and do the remove/clean/rescan trick on them, but it would be really appreciated if this recently introduced bug could be fixed since I guess more people than me and Jaarde try to improve/retag the files after the initial scan even though people might not have noticed yet (I didn't notice until this week).
Souldrinker
 
Posts: 13
Joined: Fri Jan 07, 2011 11:18 pm

Re: Folder/album is lost when its tags are changed

Postby Souldrinker » Wed Oct 04, 2017 6:47 pm

Well, it seems we're not the only ones having this issue.

When digging deeper into the forums I found these threads describing the same issue:
viewtopic.php?f=4&t=17388
viewtopic.php?f=2&t=17158

Really annoying...
Souldrinker
 
Posts: 13
Joined: Fri Jan 07, 2011 11:18 pm

Re: Folder/album is lost when its tags are changed

Postby jeffgt14 » Wed Oct 04, 2017 9:49 pm

Yea this is ridiculous. Jumped to Airsonic because of this issue and a bit tired of constantly having more and more issues with Subsonic with practically no responses from dev anymore. Airsonic seems to have the same dang problem though. At least I’m not paying for that one though.
jeffgt14
 
Posts: 34
Joined: Tue Nov 18, 2014 9:35 pm

Re: Folder/album is lost when its tags are changed

Postby D1891 » Wed Oct 18, 2017 9:17 pm

Same happens for me. Everytime I edit some tags and re-scan the library, the tracks are lost. I then have to remove/re-add the folder and do a new scan for the tracks to show again.
D1891
 
Posts: 8
Joined: Fri Sep 12, 2014 4:54 pm

Re: Folder/album is lost when its tags are changed

Postby lonesomerider » Fri Oct 20, 2017 9:36 am

D1891 wrote:Same happens for me. Everytime I edit some tags and re-scan the library, the tracks are lost. I then have to remove/re-add the folder and do a new scan for the tracks to show again.


Instead of removing/adding ("track dance") the tracks try the following :

open up the url <UrlOfSubsonic>/db.view

and execute the follwing sql:

Code: Select all
UPDATE MEDIA_FILE
SET children_last_updated = '1970-01-01 01:00:00.0'
WHERE TYPE IN ( 'ALBUM', 'DIRECTORY')

or
Code: Select all
UPDATE MEDIA_FILE
SET children_last_updated = '1970-01-01 01:00:00.0'
WHERE TYPE IN ( 'ALBUM', 'DIRECTORY')
AND PATH LIKE '%FOLDER NAME%'

then do a rescan of the library.

this helped me to recover 2% of missing songs after the upgrade to 6.1.1
/lonesomerider

Image
lonesomerider
 
Posts: 26
Joined: Fri Oct 20, 2017 9:09 am
Location: Switzerland

Re: Folder/album is lost when its tags are changed

Postby D1891 » Sun Oct 22, 2017 11:44 am

Great advise, it works. Thanks!
D1891
 
Posts: 8
Joined: Fri Sep 12, 2014 4:54 pm

Re: Folder/album is lost when its tags are changed

Postby JamMstrT » Tue Oct 24, 2017 5:54 pm

Jaarde wrote:If I change tags of tracks and scan the library again, Subsonic looses those tracks and won't show them at least in frontend player. No matter if I rescan or cleanup database and rescan after that, it won't find the tracks anymore.


I have seen and posted about this as well.

I have been able to work around it by creating a CMD file and an "almost" empty TXT file on my server. The TXT file I named UPDATE.TXT and I rotate it between containing a value of 1 or 2 and saving it to update the modification date on the file. The CMD file then proceeds to copy the TXT file into every directory and sub-directory. With this updated TXT file in place, Subsonic seems to re-scan all of the folders.

After making changes to a tags or Album Art, I now just update the TXT file and then run the CMD file and then re-scan the files in Subsonic.

Contents of CMD:

for /r "d:\Music" %%i in (.) do copy /y "c:\update.txt" "%%i"
Regards,
T

If at first you don't succeed, destroy all evidence that shows you tried.
JamMstrT
 
Posts: 12
Joined: Fri Nov 16, 2012 5:05 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 25 guests