Missing track/album files in library - detailed description

Need help? Post your questions here.

Moderator: moderators

Missing track/album files in library - detailed description

Postby jtodd » Sat Feb 04, 2017 11:01 pm

Problem Description: I've just pulled in my music library after paying for the lifetime premium license, and there are some missing tracks which I know exist but are not shown. The Utah Saints album called "Utah Saints" (self-titled albums are not unusual) doesn't show up with any tracks, nor does their album "Two". I know with certainty that the files exist, are valid, and have correct permissions. Other albums/tracks in the same library (/music/jt-music/) work correctly, and have identical permissions and were ripped at the same time (I did all my albums at once.)

This worries me because I have no idea what other albums might be missing - this is the second or third track I tried playing, and it's very disheartening to find such a failure because now I have no faith that my library is actually usefully accessible with Subsonic - it's only "partial" which is worse than "not at all."

Troubleshooting Steps: Tried multiple re-scans of directories, looked in different clients to see if it showed up. The album name "Utah Saints" shows up, as does "Two" (their other album) but there are no tracks inside either. Searching on full or partial song names leads to no results as well.

Playback Application and version: Web (Chrome)
Subsonic Version: 6.0 (build a7857c) – April 30, 2016 (Premium lifetime license)
Server Version: jetty-6.1.x, java 1.7.0_121, Linux (114.7 MB / 191.2 MB)
Hardware Platform: Ubuntu 14.04.3 LTS on VMWare ESXi 5.5
Java Memory Limit: unknown
Problem Filename: /music/jt-music/Utah Saints/Utah Saints/*
Output from ffmpeg -i:
Code: Select all
root@crash:/music/jt-music# /var/subsonic/transcode/ffmpeg -i /music/jt-music/Utah\ Saints/Utah\ Saints/10\ Too\ Much\ To\ Swallow\,\ Pt.\ 1.mp3  /tmp/foo.mp3
ffmpeg version 3.0-static http://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 5.3.1 (Debian 5.3.1-8) 20160205
  configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --enable-libmfx --cc=gcc
  libavutil      55. 17.103 / 55. 17.103
  libavcodec     57. 24.102 / 57. 24.102
  libavformat    57. 25.100 / 57. 25.100
  libavdevice    57.  0.101 / 57.  0.101
  libavfilter     6. 31.100 /  6. 31.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
[mp3 @ 0xc737e80] Skipping 0 bytes of junk at 2230.
[mp3 @ 0xc737e80] Estimating duration from bitrate, this may be inaccurate
Input #0, mp3, from '/music/jt-music/Utah Saints/Utah Saints/10 Too Much To Swallow, Pt. 1.mp3':
  Metadata:
    track           : 10/10
    encoded_by      : iTunes v7.3.2
    title           : Too Much To Swallow, Pt. 1
    artist          : Utah Saints
    album           : Utah Saints
    genre           : Electronica/Dance
    date            : 1992
  Duration: 00:03:25.64, start: 0.000000, bitrate: 192 kb/s
    Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16p, 192 kb/s
Output #0, mp3, to '/tmp/foo.mp3':
  Metadata:
    TRCK            : 10/10
    TENC            : iTunes v7.3.2
    TIT2            : Too Much To Swallow, Pt. 1
    TPE1            : Utah Saints
    TALB            : Utah Saints
    TCON            : Electronica/Dance
    TDRC            : 1992
    TSSE            : Lavf57.25.100
    Stream #0:0: Audio: mp3 (libmp3lame), 44100 Hz, stereo, s16p
    Metadata:
      encoder         : Lavc57.24.102 libmp3lame
Stream mapping:
  Stream #0:0 -> #0:0 (mp3 (native) -> mp3 (libmp3lame))
Press [q] to stop, [?] for help
size=    3214kB time=00:03:25.63 bitrate= 128.0kbits/s speed=15.3x
video:0kB audio:3213kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.012885%
root@crash:/music/jt-music#


Last ten log file lines:
Code: Select all
[2/4/17 2:29:06 PM PST]   INFO   MediaScannerService   Scanned media library with 70750 entries.
[2/4/17 2:29:06 PM PST]   INFO   MediaScannerService   Scanned media library with 70858 entries.
[2/4/17 2:29:06 PM PST]   INFO   MediaScannerService   Marking non-present files.
[2/4/17 2:29:09 PM PST]   INFO   MediaScannerService   Marking non-present artists.
[2/4/17 2:29:09 PM PST]   INFO   MediaScannerService   Marking non-present albums.
[2/4/17 2:29:09 PM PST]   INFO   MediaScannerService   Completed media library scan.
[2/4/17 2:29:09 PM PST]   INFO   PlaylistService   Starting playlist import.
[2/4/17 2:29:09 PM PST]   INFO   PlaylistService   Completed playlist import.


And a directory listing:
Code: Select all
root@crash:/music/jt-music# dir /music/jt-music/Utah\ Saints/Utah\ Saints/
total 79732
    4 drwxr-xr-x 2 jtodd jtodd     4096 Dec 10  2007 .
    4 drwxr-xr-x 5 jtodd jtodd     4096 Dec 10  2007 ..
8396 -rw-r-xr-x 1 jtodd jtodd  8594425 Dec 10  2007 01 Something Good.mp3
6532 -rw-r-xr-x 1 jtodd jtodd  6687905 Dec 10  2007 02 I Want You.mp3
8624 -rw-r-xr-x 1 jtodd jtodd  8830781 Dec 10  2007 03 What Can You Do For Me.mp3
10820 -rw-r-xr-x 1 jtodd jtodd 11077103 Dec 10  2007 04 Soulution.mp3
9004 -rw-r-xr-x 1 jtodd jtodd  9216349 Dec 10  2007 05 States Of Mind.mp3
6336 -rw-r-xr-x 1 jtodd jtodd  6487911 Dec 10  2007 06 New Gold Dream (81-82-83-84).mp3
6028 -rw-r-xr-x 1 jtodd jtodd  6171307 Dec 10  2007 07 Kinetic Synthetic.mp3
9860 -rw-r-xr-x 1 jtodd jtodd 10096571 Dec 10  2007 08 My Mind Must Be Free.mp3
9300 -rw-r-xr-x 1 jtodd jtodd  9519787 Dec 10  2007 09 Trance Atlantic Glide.mp3
4824 -rw-r-xr-x 1 jtodd jtodd  4937493 Dec 10  2007 10 Too Much To Swallow, Pt. 1.mp3
root@crash:/music/jt-music# dir /music/jt-music/Utah\ Saints
total 52
4 drwxr-xr-x   5 jtodd jtodd  4096 Dec 10  2007 .
36 drwxrwxrwx 832 root  root  36864 Feb  4 13:08 ..
4 drwxr-xr-x   2 jtodd jtodd  4096 Dec  9  2007 Perfecto Presents... Travelling (Disc 2)
4 drwxr-xr-x   2 jtodd jtodd  4096 Dec 10  2007 Two
4 drwxr-xr-x   2 jtodd jtodd  4096 Dec 10  2007 Utah Saints
root@crash:/music/jt-music#
jtodd
 
Posts: 2
Joined: Sat Feb 04, 2017 10:43 pm

Re: Missing track/album files in library - detailed descript

Postby protonis » Sun Jul 23, 2017 10:06 am

Hi,
did you get any response regarding your decribed problem? I have a similar problem on Version 6.1.1 (Build fc853b). I'm pretty sure in older releases it worked proper. But not i also miss many tracks/albums that are exist on my NAS. I also synchronized all Music-Content at once (all rights are set the same for everything).

What i also tried after many complete readings was to copy or move a single album just into another folder. And sometimes (not everytime) it worked so that this album was available after sync in SubSonic. But thats not "THE" solution.

Could this be a problem of current version?

Thanks!!

Oli
protonis
 
Posts: 1
Joined: Sun Jul 23, 2017 9:55 am

Re: Missing track/album files in library - detailed descript

Postby jtodd » Sun Jul 23, 2017 5:40 pm

Oli -
Sorry, no response yet on the threat or to me in person. Not sure if I should file a bug or .... ?

JT
jtodd
 
Posts: 2
Joined: Sat Feb 04, 2017 10:43 pm

Re: Missing track/album files in library - detailed descript

Postby hairbag » Sun Jul 23, 2017 10:02 pm

I have the problem too, windows 10 server 6.1.1... the database issues are ridiculous. I love subsonic and have been a premium user for some time now but this latest build needs to be fixed asap or I will need to start looking for a better option. :(
hairbag
 
Posts: 3
Joined: Sun Jul 23, 2017 9:54 pm

Re: Missing track/album files in library - detailed descript

Postby philh99 » Fri Jul 28, 2017 5:42 pm

hairbag wrote:I have the problem too, windows 10 server 6.1.1... the database issues are ridiculous. I love subsonic and have been a premium user for some time now but this latest build needs to be fixed asap or I will need to start looking for a better option. :(


I have the problem also, but Is their a better option?
philh99
 
Posts: 5
Joined: Fri Oct 24, 2014 2:48 pm

Re: Missing track/album files in library - detailed descript

Postby philh99 » Sat Jul 29, 2017 8:18 am

as well as the subsonic web interface I also use the android app Dsub, oddly the app shows the newly added files where as the web interface doesnt.

:? :? :?
philh99
 
Posts: 5
Joined: Fri Oct 24, 2014 2:48 pm

Re: Missing track/album files in library - detailed descript

Postby Exrace » Sat Jul 29, 2017 10:54 am

That's an interesting finding.
So possible the browser interface is having issues. Wonder if a new login user displays differently?
Exrace
 
Posts: 210
Joined: Thu Nov 11, 2010 5:02 am

Re: Missing track/album files in library - detailed descript

Postby mason » Sat Jul 29, 2017 10:55 am

I have the same issue, but somehow it only started recently. If I replace a album with another version which where formerly present in Subsonic it won't show any files or only 2-3 after a rescan.
Newly added albums are working with all tracks. I then removed the album from the filebase, rescanned, cleaned the db, readded and scanned again.. then its properly showing up.
Weird thing is there was no update of the server or anything... it was working properly all the time before!?
User avatar
mason
 
Posts: 29
Joined: Tue Apr 07, 2009 12:13 pm

Re: Missing track/album files in library - detailed descript

Postby Exrace » Sat Jul 29, 2017 11:22 am

Wonder if db sub process is running out of memory.
Maybe increase the memory allocation to see if it helps?
Exrace
 
Posts: 210
Joined: Thu Nov 11, 2010 5:02 am

Re: Missing track/album files in library - detailed descript

Postby mason » Sat Jul 29, 2017 11:29 am

I have max memory at --max-memory=2048 which should be sufficient imho. Lib is around 1,5TB with 250k tracks... at least it was working fine pre 6.1.1.
Currently in the process of restoring an old db backup from 6.0.1 since I don't know whats all missing.

Edit: i restored old db, everything is fine. upgraded db to latest shema, rescanned, same albums missing. WTH?! Guess I revert the whole thing to an old version.

Editedit: Reverted everything back to 6.0 working as expected.. guess I'll wait for some future update :/
User avatar
mason
 
Posts: 29
Joined: Tue Apr 07, 2009 12:13 pm

Re: Missing track/album files in library - detailed descript

Postby jharveytx » Sat Oct 07, 2017 6:25 pm

Suffering same.
jharveytx
 
Posts: 7
Joined: Fri Jun 03, 2011 2:05 pm

Re: Missing track/album files in library - detailed descript

Postby tovine » Tue Oct 17, 2017 7:32 pm

Exactly the same issue here - copied the songs to a different folder and everything worked just fine. This is so strange and leads me to believe something is strange in the way the DB is used.
Nuking the DB folders and starting clean seems to have done the trick, but it's a bit strange that it should be necessary when cleaning the db from the user interface should have purged any reference to the files that were not found?
tovine
 
Posts: 3
Joined: Fri Oct 17, 2014 1:01 am

Re: Missing track/album files in library - detailed descript

Postby mason » Wed Oct 18, 2017 8:02 am

guess only sindre could shed light onto this. but i hate to loose my db, i have playcounts, comments, ratings and stuff for over 8 years now in it.
User avatar
mason
 
Posts: 29
Joined: Tue Apr 07, 2009 12:13 pm

Re: Missing track/album files in library - detailed descript

Postby SmplyUnprdctble » Thu Oct 19, 2017 1:36 pm

I had something similar -- except, I was getting a partial track listing instead of the full track listing for an album.

I renamed the album folder, scanned, it showed up, then renamed it back to what it was supposed to be, rescanned, and it was fine.

Not sure why it didn't like it in the first place.
SmplyUnprdctble
 
Posts: 21
Joined: Thu Apr 22, 2010 3:33 pm

Re: Missing track/album files in library - detailed descript

Postby lonesomerider » Fri Oct 20, 2017 9:16 am

Did you try to open up the url

<UrlOfSubsonic>/db.view

and execute the follwing sql:

Code: Select all
UPDATE MEDIA_FILE
SET children_last_updated = '1970-01-01 01:00:00.0'
WHERE TYPE IN ( 'ALBUM', 'DIRECTORY')


then do a rescan of the library.

this helped me to recover 2% of missing songs after the upgrade to 6.1.1
/lonesomerider

Image
lonesomerider
 
Posts: 26
Joined: Fri Oct 20, 2017 9:09 am
Location: Switzerland


Return to Help

Who is online

Users browsing this forum: No registered users and 6 guests