Subsonic 4.1.beta1 released

Announcements and discussion of new releases.

Moderator: moderators

Subsonic 4.1.beta1 released

Postby sindre_mehus » Sun Aug 22, 2010 9:23 am

Dear Subsonic users,

Subsonic 4.1.beta1 has been released with important bug fixes and some new features.

Please report any issues in this thread.

Thank you 8)
Sindre
Subsonic developer
User avatar
sindre_mehus
 
Posts: 1955
Joined: Tue Nov 29, 2005 6:19 pm
Location: Oslo, Norway

Error creating thumbnails

Postby ccandreva » Mon Aug 23, 2010 1:39 am

I'm getting an error trying to create thumbnails:

Exception java.io.IOException
Message Failed to create thumbnail for /media3/FLAC/DeYoung, Dennis/The Music of Styx Live With Symphony Orchestra/cover.jpg. Could not initialize class sun.awt.X11GraphicsEnvironment
Java version Sun Microsystems Inc. 1.6.0_21
Operating system Linux 2.6.33.6-147.2.4.fc13.i686
Server jetty-6.1.x
Memory Used 56 of 95 MB
Stack trace java.io.IOException: Failed to create thumbnail for /media3/FLAC/DeYoung, Dennis/The Music of Styx Live With Symphony Orchestra/cover.jpg. Could not initialize class sun.awt.X11GraphicsEnvironment at net.sourceforge.subsonic.controller.CoverArtController.getCachedImage(CoverArtController.java:154) at net.sourceforge.subsonic.controller.CoverArtController.handleRequest(CoverArtController.java:93) at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:48) at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:875) at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:807) at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:571) at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:501) at javax.servlet.http.HttpServlet.service(HttpServlet.java:715) at javax.servlet.http.HttpServlet.service(HttpServlet.java:820) at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:265) at org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:107) at org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:72) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.wrapper.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:81) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.ui.logout.LogoutFilter.doFilter(LogoutFilter.java:110) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249) at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:275) at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:149) at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084) at net.sourceforge.subsonic.filter.RequestEncodingFilter.doFilter(RequestEncodingFilter.java:43) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084) at net.sourceforge.subsonic.filter.ParameterDecodingFilter.doFilter(ParameterDecodingFilter.java:54) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084) at net.sourceforge.subsonic.filter.BootstrapVerificationFilter.doFilter(BootstrapVerificationFilter.java:54) at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084) at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360) at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216) at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181) at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:712) at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405) at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139) at org.mortbay.jetty.Server.handle(Server.java:313) at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:506) at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:830) at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514) at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211) at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:381) at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:396) at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)
User avatar
ccandreva
 
Posts: 104
Joined: Fri May 28, 2010 8:22 pm

Postby ccandreva » Mon Aug 23, 2010 1:56 am

Ah -solved it by adding

-Djava.awt.headless=true

to /usr/bin/subsonic
User avatar
ccandreva
 
Posts: 104
Joined: Fri May 28, 2010 8:22 pm

problems with audio embed

Postby Emergence » Mon Aug 23, 2010 3:09 am

I am having problems calling the stream api call

I am calling stream.view directly in the browser, the browser is getting a 206 response header for the partial content but it doesn't seem to be flushing out the new content to the buffer.

I would expect it to pretty much the same as
http://radio.hiof.no/nrk-alltid-nyheter-128

Where if you paste that into the chrome web address bar it will load up the player and is able to start streaming.

When you look at the source for the radio channel its quite interesting as the source will just keep getting written to as the data gets read in.

Let me know if I can be any assistance
Emergence
 
Posts: 11
Joined: Thu Jul 15, 2010 1:34 am

Postby famish99 » Mon Aug 23, 2010 3:48 am

I'm still having problems with transcoding flac songs with foreign characters (namely Japanese in this case).

Code: Select all
[8/22/10 10:23:29 PM CDT]     INFO   VersionService   Resolved local Subsonic version to: 4.1.beta1
[8/22/10 10:23:29 PM CDT]    INFO   VersionService   Resolved latest Subsonic final version to: 4.0.1
[8/22/10 10:23:29 PM CDT]    INFO   VersionService   Resolved latest Subsonic beta version to: 4.1.beta1
[8/22/10 10:23:47 PM CDT]    INFO   PlaylistInputStream   admin listening to "Katanagatari 02\1 - Refulgence.flac"
[8/22/10 10:23:47 PM CDT]    DEBUG   TranscodeInputStream   Starting transcoder: [c:\subsonic\transcode\flac] [-c] [-s] [-d] [c:\Users\famish99\Music\少女病\Katanagatari 02\1 - Refulgence.flac]
[8/22/10 10:23:47 PM CDT]    DEBUG   TranscodeInputStream   Starting transcoder: [c:\subsonic\transcode\lame] [-b] [128] [-] [-]
[8/22/10 10:23:47 PM CDT]    DEBUG   InputStreamReaderThread   (c:\subsonic\transcode\flac)
[8/22/10 10:23:47 PM CDT]    DEBUG   InputStreamReaderThread   (c:\subsonic\transcode\flac) 1 - Refulgence.flac: ERROR initializing decoder
[8/22/10 10:23:47 PM CDT]    DEBUG   InputStreamReaderThread   (c:\subsonic\transcode\flac) state = FLAC__FILE_DECODER_ERROR_OPENING_FILE
[8/22/10 10:23:47 PM CDT]    DEBUG   InputStreamReaderThread   (c:\subsonic\transcode\flac)
[8/22/10 10:23:47 PM CDT]    DEBUG   InputStreamReaderThread   (c:\subsonic\transcode\flac) An error occurred opening the input file; it is likely that it does not exist
[8/22/10 10:23:47 PM CDT]    DEBUG   InputStreamReaderThread   (c:\subsonic\transcode\flac) or is not readable.


This is on a Windows 7 Ultimate x64 machine. I think the problem is that the file names and paths are in Windows are encoded in utf16, so perhaps the forced utf8 encoding in Subsonic doesn't allow it to play nicely. I used to be able to get foreign characters to transcode properly before 4.0.1.
Last edited by famish99 on Tue Aug 24, 2010 2:33 pm, edited 2 times in total.
famish99
 
Posts: 5
Joined: Mon Aug 23, 2010 3:44 am

Postby mwgilbert » Mon Aug 23, 2010 6:52 pm

Changing themes seems to have stopped working, upgraded from 4.0.1.

Tried: restarting Subsonic, clearing browser cache
mwgilbert
 
Posts: 5
Joined: Tue Apr 14, 2009 6:04 pm

Postby Andreas » Tue Aug 24, 2010 3:28 am

Andreas
 
Posts: 39
Joined: Fri Sep 26, 2008 10:50 am
Location: Kirkenes

Can't login to beta

Postby pdcorcoran » Tue Aug 24, 2010 9:00 am

HTTP ERROR: 404
NOT_FOUND
RequestURI=/index.view

Powered by Jetty://
pdcorcoran
 
Posts: 19
Joined: Mon May 11, 2009 1:52 am

Missing Covers

Postby Alsaya » Tue Aug 24, 2010 5:00 pm

Now I don't see the different covers of multi cd albums or more worse I don't see any multi cd albums covers at all.
I've a Folder.jpg in every folder where the files are stored, but now I would need one in the album folder to see the album, that's an unwelcome change
Last edited by Alsaya on Fri Aug 27, 2010 4:09 am, edited 1 time in total.
Subsonic on Server 2012, only flac
Image
Alsaya
 
Posts: 66
Joined: Thu Feb 04, 2010 2:46 pm

Postby utopian » Tue Aug 24, 2010 7:24 pm

worked fine for me..one thing any chance that any upgrades can leave the port number unchnaged ie not change it back to 80

Thanks and a great app...
User avatar
utopian
 
Posts: 111
Joined: Sun Feb 14, 2010 3:52 pm

Postby Kirk » Wed Aug 25, 2010 12:39 am

I've had issues with iSub being unable to load playlists ever since the update... I have another server running an older version of Subsonic and it's still working fine for that server.

I assume this is something the iSub developer will have to take care of in his next update, but I thought I'd mention it.

Cheers,
Kirk
Image
User avatar
Kirk
 
Posts: 310
Joined: Tue Jun 08, 2010 5:45 pm
Location: Illinois, USA

Postby serond » Wed Aug 25, 2010 12:54 pm

Got the same problem with the chat as before. After deleting the work directory everything worked!

Nice work!
serond
 
Posts: 11
Joined: Tue Mar 30, 2010 7:32 pm

Re: Can't login to beta (Solved)

Postby pdcorcoran » Thu Aug 26, 2010 12:12 am

pdcorcoran wrote:HTTP ERROR: 404
NOT_FOUND
RequestURI=/index.view

Powered by Jetty://


Solved by reinstalling. Don't know why it didn't install right the first time.
Now that it's running, great job! I like the newer themes as well.
pdcorcoran
 
Posts: 19
Joined: Mon May 11, 2009 1:52 am

Postby tj78492 » Thu Aug 26, 2010 3:04 am

Podcast with special characters in the feed title fail to download because subsonic tries to create a folder with those characters

Ex. Anything from blogtalkradio.com, the feed title contains a | and wont download.
tj78492
 
Posts: 17
Joined: Thu Aug 26, 2010 3:01 am

Postby erncic » Thu Aug 26, 2010 5:10 am

Cannot launch 4.1 Beta 1 on PPC Mac OS 10.5.8.

Uncaught exception in main method: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'controller' defined in class path resource [applicationContext-mac.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [net.sourceforge.subsonic.booter.mac.SubsonicController]: Constructor threw exception; nested exception is java.lang.NoClassDefFoundError: java/awt/TrayIcon
erncic
 
Posts: 4
Joined: Fri Jul 30, 2010 4:40 pm

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 6 guests