Subsonic Package for Synology NAS

Announcements and discussion of new releases.

Moderator: moderators

Re: Subsonic Package for Synology NAS

Postby j79 » Tue Aug 26, 2014 10:00 am


Which version of Java have you installed ?

Could you post your log file.
I'm not an expert but I can try to check if I see something which could be wrong.

Posts: 6
Joined: Tue Jul 08, 2014 9:39 am

Re: Subsonic Package for Synology NAS

Postby houdini2930 » Tue Sep 23, 2014 3:17 am

I can confirm that boing's instructions work for 5.0
Posts: 15
Joined: Wed Jan 11, 2012 7:45 pm

Re: Subsonic Package for Synology NAS

Postby Dubhead » Wed Oct 29, 2014 4:25 am


I had finally gotten my Subsonic working well enough after my other issues I posted about earlier and recently tried to update to version 5.0 per houdini2930's indication that it works fine following the manual install instructions from boing. I followed these and downloaded the appropriate package and moved (overwrote) the two subsonic files. Unfortunately, my Subsonic service will not start now and I fear that I will have to reconfigure everything again. When I attempted to run the service from the Package Center after slipping in v.5 files, I got the message that it could not start the package. I validated the permissions and they were correct. I uninstalled the package from the package center and now I think I am just stuck with having to reconfigure the whole installation from scratch again. :(

Does anyone have a more foolproof method to install v.5.0 from a fresh installation? Also, how do I clear out everything and start over? Should I dump Serviio, Java and everything and start completely fresh? Does Subsonic work with Java v. 8 (which I currently have installed). Using PuTTY has been a pain in the ass for me as I suck with Unix and Cyberduck was much easier for me to navigate and move files about (including updating permissions) but I can't even get that to work to access the /usr folders or other root-level folders even after enabling SFTP in File Services.

Basically feeling defeated by this process because it worked beautifully for a short time and now it is a train wreck thanks to me. Any help on this is appreciated.

~Dubhead :evil:
Posts: 3
Joined: Sun Aug 24, 2014 10:50 pm

Re: Subsonic Package for Synology NAS

Postby Dubhead » Thu Oct 30, 2014 5:59 am

Update. I decided to go ahead and install the Madsonic .spk fork(v.5.1-B5060-016) of Subsonic on my Synology DS 1813+ running DSM 5.0-4528 Update 1, Java SE Embedded 7 v.1.7.0_71-0028, and Serviio v. This installed easily and seems to be running normally but I have now run back into the classic issue of the application not recognizing the file path to my audio files again. I had posted about this in other threads and eventually found the solution of changing the permissions on the path to be that of the subsonic daemon user per some other forum users feedback. This seemed to work for me when I was using subsonic on the Synology NAS, and now that Madsonic is installed, there is a similar madsonic daemon user which I once again made the owner of the file path (and subdirectories/files) that I am attempting to get it to recognize. This has not worked in this instance for some reason. I am really not sure why this is such an issue or the logic behind what kind of permissions Subsonic/Madsonic needs in order to recognize the appropriate file path for audio files on the NAS.

Any ideas or information on what really needs to happen here? I feel like there are a lot of stabs in the dark at this until it just works but I haven't really found much definitive answer for it. Here is the other post I had about the permissions from Synology forums: ... ding+media

Dubhead 8)
Posts: 3
Joined: Sun Aug 24, 2014 10:50 pm


Return to Announcements

Who is online

Users browsing this forum: No registered users and 3 guests