Tracks not showing up in Search

General discussions.

Moderator: moderators

Tracks not showing up in Search

Postby kayvee » Wed Nov 30, 2016 5:11 pm

Lately, I have noticed that a lot of tracks/albums do not show up in search results although they are clearly present in the library. I can navigate to these files from the "A-Z Index" and play without any issues. I saw an earlier thread regarding a similar issue in this forum: viewtopic.php?t=6848 but the setting to reindex appears to have been removed from the Settings in version 6. Is there a way to reindex the library without going for the nuclear option of rebuilding everything?
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm

Re: Tracks not showing up in Search

Postby kayvee » Thu Dec 01, 2016 1:22 pm

Not sure if this is related to the search index function but another thing I have noticed is that the "Media collection" statistics in the About Subsonic page shows only about 3000 tracks whereas my library has ~15000 tracks. When I restart the subsonic service the collection statistics show up correctly with ~15000 tracks but once I invoke the Settings > Media Folders > Scan media folders now, I end up with the small media collection.
Regardless of what's shown in the Media collection statistics the search functionality does not work for certain files. Not sure why.
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm

Re: Tracks not showing up in Search

Postby kayvee » Fri Dec 16, 2016 3:05 pm

bump
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm

Re: Tracks not showing up in Search

Postby toolman » Fri Dec 16, 2016 6:51 pm

It's all related to the tags I think.
I know that a lot of my files aren't properly tagged and therefor never show up in the search results.
In Subsonic all my mediafiles are visible.
Subsonic tells me that I have 144,897 songs, but if I use another program to count my songs it detects about 10.000 songs more.
toolman
 
Posts: 537
Joined: Fri Dec 11, 2009 4:18 pm
Location: Netherlands

Re: Tracks not showing up in Search

Postby kayvee » Mon Dec 19, 2016 4:34 pm

I doubt that is the case. I have not changed the ID3 tags for the majority of tracks in the recent past. Yet, they have become 'unsearchable'. I am certain that they were indexed earlier. One change that I have made and might be the reason is the folder organization: I used to have them arranged as Album/Track which I changed to the recommended Artist/Album/Track mode. That's why I was hoping to find a way to force subsonic to reindex my files.
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm

Re: Tracks not showing up in Search

Postby toolman » Tue Dec 20, 2016 7:07 am

The only sure way would be to disable all your mediafolders, do a folderscan, cleanup database, enable mediafolders and do a folderscan again.
In this proces however you are likely to lose your starratings and comments, as well as "times played" and "date added".
toolman
 
Posts: 537
Joined: Fri Dec 11, 2009 4:18 pm
Location: Netherlands

Re: Tracks not showing up in Search

Postby kayvee » Tue Dec 20, 2016 12:46 pm

I was hoping to avoid that. I have a large number of Albums/Tracks with star ratings that I would hate to lose.
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm

Re: Tracks not showing up in Search

Postby toolman » Tue Dec 20, 2016 3:02 pm

I fear that by changing the foldernames you've already lost that info.
I don't know for sure if Subsonic writes the starrating to the tracks or if it's stored in the database.
In the past I have had the ecperience that all that info got lost when I had to do a new Subsonic installation.
I know for sure that Comments are stored in the database and are lost if you move the track to another location or rename the folder.
toolman
 
Posts: 537
Joined: Fri Dec 11, 2009 4:18 pm
Location: Netherlands

Re: Tracks not showing up in Search

Postby kayvee » Tue Dec 20, 2016 3:09 pm

I fear that by changing the foldernames you've already lost that info.

Sorry, I wasn't clear earlier... I did all the starring *after* changing the folder structure. So, the ratings are all intact now. But I see your point and unfortunately, I think I just have to swallow the bitter pill and do it the hard way... :sad:
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm

Re: Tracks not showing up in Search

Postby bbateman » Sun Jan 29, 2017 8:24 pm

I've seen the same thing and I found the solve in my case...

If you have music sorted like this:

Folder(Artist Name)/Folder(Album 1)/Music Files
Folder(Artist Name)/Folder(Album 2)/Music Files
Folder(Artist Name)/Folder(Album 3)/Music Files
Folder(Artist Name)/Music Files [NOT IN AN ALBUM FOLDER]

I found that the last section where the music files arent in a subfolder would not show in the search. If I placed them in a subfolder matching the rest of the files - it would show up.

Bill
Last edited by bbateman on Tue Jan 31, 2017 2:58 am, edited 1 time in total.
bbateman
 
Posts: 4
Joined: Sun Mar 27, 2016 7:15 pm

Re: Tracks not showing up in Search

Postby kayvee » Mon Jan 30, 2017 1:54 am

@bbateman -- you may be correct. Unfortunately, I have no way to check. I swallowed the bitter pill and redid my entire library. It is now organized in the [Album]/[Track.mp3] format.
kayvee
 
Posts: 51
Joined: Fri Apr 10, 2009 7:26 pm


Return to General

Who is online

Users browsing this forum: No registered users and 10 guests