Videos vs music

General discussions.

Moderator: moderators

Videos vs music

Postby columbiabbs » Thu Oct 28, 2010 6:53 pm

I think I have the Music side of subsonic working now,but can we add
Video's or movies to our system that could be played or download if
someone wanted to.?

wt. :?:
columbiabbs
 
Posts: 52
Joined: Sun Oct 03, 2010 3:10 am
Location: COLUMBIA,SC

Postby GJ51 » Sun Oct 31, 2010 7:09 am

The easiest way to do it is to set up an external player that opens your default media player on your local machine. I downloaded the latest klite codecs and made sure that I went through the setup to ensure that the setting for .m3u was enabled. Subsonic will pass the playlist to the external player if you select that definition when you define the player.

Next, define and label the External player for each user that will access video. When you want to watch video, just select the proper player. The Media Player Classic that comes with the Klite codecs does a great job.
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3492
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York

Postby Mycophiles » Mon Nov 01, 2010 1:16 am

What are the stipulations here?

For Myself I have subsonic running on a dedicated windows server. I'm running the latest version of subsonic but I have seen and gone through the steps of trying to get subsonic to stream video but while it recognizes the videos I add it does not play them in the browser plugin.

If I just allow the server to recognize the movies and tv shows then use the subsonic app ( airsub or browser ) to use a standalone video player like WMP to run the shows on the client side will it work?

Need a bit more detail.
Mycophiles
 
Posts: 9
Joined: Mon May 24, 2010 5:15 pm

Postby GJ51 » Mon Nov 01, 2010 1:34 am

If you set up an external player, Subsonic will pass your selection to your default player on your desktop. If WMP is your default player, it will play many common video files. I suggest installing the full Klite codec pack to enable the widest selection of file types.

It still has a few glitches. I can play some of my avi files in WMP on my local machine, but if I copy the file to the server and try to play the same file through Subsonic, I get an error. .wmv and .mp4 files work fine.

The Media Player Classic player that comes with the Klite install plays the same files just fine, but it too has its own set of little glitches.

The most sensible approach would be to first decide which Player you want to use, than convert all the video files you want to play from the server into a format that works well with that player.

Not a polished setup, but it can be made to work.

I'm not sure what all you have done to try to get the embedded player to work with video, but the process to set that up is way more involved. I think I may have some problems in the way I did mine as it often takes switching players several times to get the video to play. I'm trying to get input from others who have video set up on the internal player to see if I can pinpoint a fix.

I'm also pretty sure that Sindre is working on making video an integral part of SS in a future upgrade. Until then, setting up the external player to call the default desktop player is a reasonable workaround.
Gary J

http://bios-mods.com
http://www.maplegrovepartners.com
http://theaverageguy.tv/category/tagpodcasts/cyberfrontiers/
User avatar
GJ51
 
Posts: 3492
Joined: Wed Oct 20, 2010 11:58 pm
Location: Western New York


Return to General

Who is online

Users browsing this forum: No registered users and 5 guests