SubRok for Amarok

Announcements and discussion of new releases.

Moderator: moderators

Re: SubRok for Amarok

Postby xtxer » Sat Mar 16, 2013 7:09 pm

Gotchya. You've made my life and many other's more convenient because of this!
xtxer
 
Posts: 15
Joined: Fri Mar 15, 2013 12:28 am

Re: SubRok for Amarok

Postby m4x1m » Sat Apr 20, 2013 1:25 pm

New Version - v1.5

DOWNLOAD LINK
http://kde-apps.org/content/show.php?content=156122

Code: Select all
v1.5:
- Added new REST API selection (1.9.0) for new Subsonic v4.8.
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby piethein » Thu May 30, 2013 7:19 pm

This script is very good, I even use it in Amarok when I am in the server's local network, because I can't get UPnP going in KDE...

Thank you m4x1m.
piethein
 
Posts: 35
Joined: Fri Dec 03, 2010 5:58 pm

Re: SubRok for Amarok

Postby piethein » Fri May 31, 2013 8:42 pm

m4x1m, so far I had not tried out playlists or random tracks. Apparently there is an issue (at least in my setup).

I use Subsonic 4.8 and SubRok 1.5.

When I select a playlist or random track, Amarok's playlist is filled with (the right number) 'stream.view' entries. Theil location is: 'https://subsonic.host.url:443/rest/stream.view?u=user&p=enc:6e692347a6f6d6534a6c6ab4b21&v=1.9.0&c=SubRok&id=11168' for example, which is probably the right location. But nothing can be played. Just selecting tracks works fine, artwork is downloading and everything.
piethein
 
Posts: 35
Joined: Fri Dec 03, 2010 5:58 pm

Re: SubRok for Amarok

Postby m4x1m » Sat Jun 01, 2013 5:35 pm

piethein wrote:m4x1m, so far I had not tried out playlists or random tracks. Apparently there is an issue (at least in my setup).

I use Subsonic 4.8 and SubRok 1.5.

When I select a playlist or random track, Amarok's playlist is filled with (the right number) 'stream.view' entries. Theil location is: 'https://subsonic.host.url:443/rest/stream.view?u=user&p=enc:6e692347a6f6d6534a6c6ab4b21&v=1.9.0&c=SubRok&id=11168' for example, which is probably the right location. But nothing can be played. Just selecting tracks works fine, artwork is downloading and everything.


Yes, I know. Amarok can't read the id3 tags until you start playing the song.
It's like when you play a song from an Internet radio, amarok reads the tags directly from the stream.
Different is when you browse the folders, because the tags are read before.

I hope I have correctly understood your notice!
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby piethein » Sun Jun 02, 2013 2:16 pm

I believe I might have been a bit unclear:

These 'stream.view' files are never played. When the playlist is filled with these files (by loading a playlist or generating them randomly) they are never played, not when I press play, not when I double-click them. When I add files from the browser to the start and end of the playlist, the first one starts to play after pressing Play, after finishing this first track Amarok jumps to the last file I had added from the browser, bypassing all 'stream.view' files in between.

So I cannot get the files to play (ofdisplay details)
piethein
 
Posts: 35
Joined: Fri Dec 03, 2010 5:58 pm

Re: SubRok for Amarok

Postby m4x1m » Mon Jun 03, 2013 9:30 am

piethein wrote:I believe I might have been a bit unclear:

These 'stream.view' files are never played. When the playlist is filled with these files (by loading a playlist or generating them randomly) they are never played, not when I press play, not when I double-click them. When I add files from the browser to the start and end of the playlist, the first one starts to play after pressing Play, after finishing this first track Amarok jumps to the last file I had added from the browser, bypassing all 'stream.view' files in between.

So I cannot get the files to play (ofdisplay details)


I can't reproduce this. I tried with the demo of subsonic server, The script taken 5 random songs and amarok played automatically the first, then amarok has played the others in order (same thing adding stream from folders). Amarok 2.5.0 (KDE 4.8.5) on Ubuntu 12.04.02. SubRok can't control the playlist, the script only add the url stream in the amarok playlist, maybe an amarok bug (my guess)? :(
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby piethein » Mon Jun 03, 2013 8:18 pm

I'm using Amarok 2.7.1 with KDE 4.10.3. It might be a bug in Amarok or maybe some change between 2.5 and 2.7?

Do you know if I might get useful output when I use the script from Amarok started with --debug options? I'll try out some things and post it here if I recognise something that might be useful
piethein
 
Posts: 35
Joined: Fri Dec 03, 2010 5:58 pm

Re: SubRok for Amarok

Postby m4x1m » Tue Jun 04, 2013 7:45 am

piethein wrote:I'm using Amarok 2.7.1 with KDE 4.10.3. It might be a bug in Amarok or maybe some change between 2.5 and 2.7?

Do you know if I might get useful output when I use the script from Amarok started with --debug options? I'll try out some things and post it here if I recognise something that might be useful


Well, normally the --debug option tell you if there are errors in the script, but when the script contain errors, it break. When SubRok adds songs to playlist, the script has finished it's work, perhaps can you check when amarok change the track?
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby waltermmm » Tue Feb 11, 2014 7:55 pm

When I use Subsonic 4.9. Do I need the 1.10.2 api?

Will this be updated, because in subrok I only can select till 1.9.

THX

Walter
waltermmm
 
Posts: 4
Joined: Tue Jul 24, 2012 12:37 pm

Re: SubRok for Amarok

Postby m4x1m » Wed Feb 12, 2014 8:25 am

waltermmm wrote:When I use Subsonic 4.9. Do I need the 1.10.2 api?

Will this be updated, because in subrok I only can select till 1.9.

THX

Walter


I'll add new API version soon, meantime you can use subsonic 4.9 without problem.
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby waltermmm » Sun Feb 23, 2014 8:09 pm

Yeah I was asking because 1.9 with SubRok does not work for me. I haven't tried other versions. Thought it has to to with the outdated api.

I'm using encryption, what can I try to get it working.

What can I try to get it working? Haven't found any log file.

THX in advance
waltermmm
 
Posts: 4
Joined: Tue Jul 24, 2012 12:37 pm

Re: SubRok for Amarok

Postby m4x1m » Mon Feb 24, 2014 11:21 am

waltermmm wrote:Yeah I was asking because 1.9 with SubRok does not work for me. I haven't tried other versions. Thought it has to to with the outdated api.

I'm using encryption, what can I try to get it working.

What can I try to get it working? Haven't found any log file.

THX in advance


Strange, I tested right now with the demo of Subsonic and works well. What is the response if you run the connection test?
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby m4x1m » Sat May 03, 2014 3:15 pm

New Version - v1.6

DOWNLOAD LINK
http://kde-apps.org/content/show.php?content=156122

Code: Select all
v1.6:
- Added new REST API selection (1.10.2) for new Subsonic v4.9.
- Added a workaround to show the track number (thanks to rsalvador).
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Re: SubRok for Amarok

Postby m4x1m » Tue Oct 20, 2015 8:23 am

New Version - v1.7

DOWNLOAD LINK
http://kde-apps.org/content/show.php?content=156122

Code: Select all
v1.7:
- Added new REST API selection for new Subsonic v5.2.1
- Add leading zero to the track numbers for a correct order in the playlist.
SubRok for Amarok by
Max (m4x1m) Headroom
User avatar
m4x1m
 
Posts: 17
Joined: Sat Dec 29, 2012 6:53 pm
Location: Italy

Previous

Return to Announcements

Who is online

Users browsing this forum: No registered users and 0 guests