Subsonic for Synology

Third-party modifications and add-ons, Apps and Clients

Moderator: moderators

Re: Subsonic for Synology

Postby DviousDogzz » Thu Mar 12, 2015 12:49 am

Thanks raydiognome!! I've followed the steps (with some help from a Linux expert) but seem to have a problem with the subsonic service in tomcat 7. Initially it will start and I can get to the subsonic page, but then after a few minutes the SS service stops and will not restart. I get the message: FAIL - Application at context path /subsonic could not be started. Any suggestions? Obviously I missed something!

EDIT: I rebooted the server and the SS service started but now I'm getting this:

HTTP Status 404 - /subsonic/WEB-INF/jsp/index.jsp
type Status report
message /subsonic/WEB-INF/jsp/index.jsp
description The requested resource is not available.
User avatar
DviousDogzz
 
Posts: 12
Joined: Sun Oct 30, 2011 10:51 pm

Re: Subsonic for Synology

Postby raydiognome » Thu Mar 12, 2015 10:50 am

Haven't run into that yet. (fingers crossed) but like producerism I too had to uninstall and re-install everything from scratch.
Wish I could help but if it wasn't for others I would not have gotten in working. Good luck and PLEASE post the solution if and when you get one
raydiognome
 
Posts: 9
Joined: Tue Mar 10, 2015 10:31 pm

Re: Subsonic for Synology

Postby raydiognome » Thu Mar 12, 2015 11:04 pm

Well....despite being able to login remotely I cannot see any album art or play anything. I get the following error: Cannot read property 'html' of null

So, figuring that I didn't set up the transcoding I ran the following command in WinSCP: ln -s /usr/syno/bin/ffmpeg /var/subsonic/transcode/ffmpeg

I stopped and started Tomcat and of course now Subsonic won't start! Just like DviousDogzz I get "FAIL - Application at context path /subsonic could not be started. "

Rebooted my Diskstation and all is well but remote access will not bring up anything now. I can connect and login but the index.view does not display anything.
raydiognome
 
Posts: 9
Joined: Tue Mar 10, 2015 10:31 pm

Re: Subsonic for Synology

Postby HippopoKiboko » Thu Mar 19, 2015 3:33 pm

Hello
Another successful way to start subsonic on synology (DS414) is to use Debian Chroot:
https://synocommunity.com/packages
Some useful info you can find alse there: https://sites.google.com/a/courville.or ... ian-chroot
After that you should install subsonic package for debian, mount /volime1 into debian and replace chrooted /var/subsonic/transcode/ffmpeg with ffmpeg from debian repository or (it is be better) to compile it yourself.
Ffmpeg compilation insruction: https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

All (video streaming, flac, music) works fine.
Except starting subsonic under non-root user.

If anybody interested in this i can write more detail info.

P.S. compiled ffmped (version 2.6.git) for DS414 you can download here: https://sites.google.com/site/maxant/files/ffmpeg
Last edited by HippopoKiboko on Thu Mar 19, 2015 3:53 pm, edited 1 time in total.
User avatar
HippopoKiboko
 
Posts: 31
Joined: Fri Sep 21, 2012 9:56 am

Re: Subsonic for Synology

Postby DviousDogzz » Thu Mar 19, 2015 3:50 pm

I am definitely interested, Hippopo! Unfortunately we (well, my linux expert friend) have been unable to successfully get subsonic working, even with all the detailed instructions from everyone. We have tried from scratch several times over, step by step and still no luck.
User avatar
DviousDogzz
 
Posts: 12
Joined: Sun Oct 30, 2011 10:51 pm

Re: Subsonic for Synology

Postby HippopoKiboko » Thu Mar 19, 2015 5:54 pm

DviousDogzz wrote:I am definitely interested, Hippopo! Unfortunately we (well, my linux expert friend) have been unable to successfully get subsonic working, even with all the detailed instructions from everyone. We have tried from scratch several times over, step by step and still no luck.


step-by-step, how to install subsonic 5.2 on synology DS414 with video transcoding
https://sites.google.com/site/maxant/others/subsonic
User avatar
HippopoKiboko
 
Posts: 31
Joined: Fri Sep 21, 2012 9:56 am

Re: Subsonic for Synology

Postby DviousDogzz » Thu Mar 19, 2015 7:22 pm

Excellent thank you! I successfully connected to the SynoCommunity for the packages, but the one missing in the list is Debian Chroot! Also the instructions say to install Python first, however, I have two options: Python3 and Python Module so I am not sure which one to select. I have a DS414J.
User avatar
DviousDogzz
 
Posts: 12
Joined: Sun Oct 30, 2011 10:51 pm

Re: Subsonic for Synology

Postby raydiognome » Thu Mar 19, 2015 10:25 pm

Hippo,

Thanks for the info and the link. I'll take a look at the directions perhaps something in there can help with my problem.
My install works fine locally except for a restart issue which may be related to your non-root user issue.

I've abandoned it for now until I get some help with my remote access issue. It was just much easier to install it on an old windows box.
raydiognome
 
Posts: 9
Joined: Tue Mar 10, 2015 10:31 pm

Re: Subsonic for Synology

Postby HippopoKiboko » Fri Mar 20, 2015 9:05 am

DviousDogzz wrote:Excellent thank you! I successfully connected to the SynoCommunity for the packages, but the one missing in the list is Debian Chroot! Also the instructions say to install Python first, however, I have two options: Python3 and Python Module so I am not sure which one to select. I have a DS414J.

Hello
I have used Python (2.7.8-11) from SynoCommunity
User avatar
HippopoKiboko
 
Posts: 31
Joined: Fri Sep 21, 2012 9:56 am

Re: Subsonic for Synology

Postby HippopoKiboko » Fri Mar 20, 2015 9:09 am

After uninstalling debian chroot, fresh install and synology reboot i receive "access denied" for some folder, and impossibility to view video from some point of time. It plays only from the start.
I try to check this issue on next weekend and will write report.
User avatar
HippopoKiboko
 
Posts: 31
Joined: Fri Sep 21, 2012 9:56 am

Re: Subsonic for Synology

Postby DviousDogzz » Fri Mar 20, 2015 3:59 pm

Yeah, unfortunately I think that I am going to give up on this also because it's becoming too complicated with all of these issues. As much as I love Subsonic, it's not worth this much trouble especially if (god forbid) the NAS has to be restored to factory defaults for some reason. I'd have to go through the whole process all over again. At this point, I can't even see Debian Chroot in my list of community packages.
User avatar
DviousDogzz
 
Posts: 12
Joined: Sun Oct 30, 2011 10:51 pm

Re: Subsonic for Synology

Postby HippopoKiboko » Fri Mar 20, 2015 4:30 pm

When you restore NAS to factory default you not lose packages like debian-chroot
User avatar
HippopoKiboko
 
Posts: 31
Joined: Fri Sep 21, 2012 9:56 am

Re: Subsonic for Synology

Postby DviousDogzz » Fri Mar 20, 2015 4:39 pm

I can't even get that package on to the NAS. It doesn't show up in the list of available packages.
User avatar
DviousDogzz
 
Posts: 12
Joined: Sun Oct 30, 2011 10:51 pm

Re: Subsonic for Synology

Postby HippopoKiboko » Mon Mar 23, 2015 3:53 pm

Hello
If you can`t download debian chroot package from syno communoty, you can make it himself.
But it requires basic linux administration skill.
I have updated information about this on my manual page.

The renewed instruction how to install and run subsonic (5.2.1) on synology (DS414):
https://sites.google.com/site/maxant/others/subsonic
User avatar
HippopoKiboko
 
Posts: 31
Joined: Fri Sep 21, 2012 9:56 am

Re: Subsonic for Synology

Postby DviousDogzz » Mon Mar 23, 2015 4:01 pm

Thanks again for taking the time to post instructions!
User avatar
DviousDogzz
 
Posts: 12
Joined: Sun Oct 30, 2011 10:51 pm

PreviousNext

Return to Mods, Apps and Clients

Who is online

Users browsing this forum: No registered users and 3 guests