Tlsv1.1 and Tlsv1.2 protocol support

Alternative Android Client for Subsonic

Moderators: daneren2005, moderators

Tlsv1.1 and Tlsv1.2 protocol support

Postby oa72 » Fri Jun 23, 2017 5:58 am

Hi, any chance of including Tlsv1.1 and Tlsv1.2 protocol support in DSub for Android 4.4?

Currently I'm running an Apache proxy server in front of my Subsonic server, but connectivity is failing from Android 4.4.4 when using https where support for (less secure) Tlsv1.0 protocol is removed. This seems not to be an issue when using Android 5. Thanks.
oa72
 
Posts: 3
Joined: Tue Mar 14, 2017 4:29 pm

Re: Tlsv1.1 and Tlsv1.2 protocol support

Postby jskier » Tue Jun 27, 2017 2:22 pm

I believe this is a limitation of KitKat; I have this version as well. Other apps I use which operate over https need tls1.0 to work because the ssl library afforded to applications running KitKat is limited to which tls versions / ciphers they can use (due to the age of the OS). Upgrading the OS is really the only way to get better support for newer versions of tls.
jskier
 
Posts: 1
Joined: Tue Jun 27, 2017 2:15 pm


Return to DSub for Android

Who is online

Users browsing this forum: No registered users and 3 guests